Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514402 - SELinux is preventing openvpn from 'open' accesses on the file 2F6574632F6F70656E76706E2F436F6E66696775726174696F6E732F4155204D656C626F75726E652E6F76706E.
Summary: SELinux is preventing openvpn from 'open' accesses on the file 2F6574632F6F70...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bab99d71ad28a4197599f7b19aa...
: 1514405 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 10:31 UTC by Jas
Modified: 2017-11-20 13:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 13:52:06 UTC


Attachments (Terms of Use)

Description Jas 2017-11-17 10:31:12 UTC
Description of problem:
SELinux is preventing openvpn from 'open' accesses on the file 2F6574632F6F70656E76706E2F436F6E66696775726174696F6E732F4155204D656C626F75726E652E6F76706E.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that openvpn should be allowed open access on the 2F6574632F6F70656E76706E2F436F6E66696775726174696F6E732F4155204D656C626F75726E652E6F76706E file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'openvpn' --raw | audit2allow -M my-openvpn
# semodule -X 300 -i my-openvpn.pp

Additional Information:
Source Context                system_u:system_r:openvpn_t:s0
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                2F6574632F6F70656E76706E2F436F6E66696775726174696F
                              6E732F4155204D656C626F75726E652E6F76706E [ file ]
Source                        openvpn
Source Path                   openvpn
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-260.13.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.13.11-200.fc26.x86_64 #1 SMP Thu
                              Nov 2 18:28:35 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-11-17 21:17:04 AEDT
Last Seen                     2017-11-17 21:17:04 AEDT
Local ID                      a6cbfe3f-fa3d-4837-a953-b5bcd9ede86e

Raw Audit Messages
type=AVC msg=audit(1510913824.85:103): avc:  denied  { open } for  pid=694 comm="openvpn" path=2F6574632F6F70656E76706E2F436F6E66696775726174696F6E732F4155204D656C626F75726E652E6F76706E dev="sda5" ino=793465 scontext=system_u:system_r:openvpn_t:s0 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file permissive=1


Hash: openvpn,openvpn_t,admin_home_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-260.13.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.13.11-200.fc26.x86_64
type:           libreport

Potential duplicate: bug 1225929

Comment 1 Lukas Vrabec 2017-11-20 13:52:06 UTC
Same issue mislabeled /etc/. Closing.

Comment 2 Lukas Vrabec 2017-11-20 13:52:19 UTC
*** Bug 1514405 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.