Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514392 - The sum of the replicas in underlying clusters don't match the desired number of replicas in the federation
Summary: The sum of the replicas in underlying clusters don't match the desired number...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.8.0
Assignee: Maru Newby
QA Contact: Qixuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 09:53 UTC by Qixuan Wang
Modified: 2017-11-17 17:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-17 17:23:40 UTC


Attachments (Terms of Use)

Description Qixuan Wang 2017-11-17 09:53:14 UTC
Description of problem:
Join federation control panel host as a member of a federation, then create a federated ReplicaSet resource and check whether the sum of the replicas in each registered cluster match the desired number of replicas in the federation. The control panel cluster also takes into the assignment. 


Version-Release number of selected component (if applicable):
openshift v3.7.7
kubernetes v1.7.6+a08f5eeb62
etcd 3.2.8
ose-federation:v3.7.7-1

How reproducible:
Always

Steps to Reproduce:
1. Given there is a running Kubernetes cluster federation

2. Create a federated ReplicaSet resource
# oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/replicaSet/tc536589/replica-set.yaml -n qwangtest --context=qwangfed

3. Very the sum of the replicas in each registered cluster match the desired number of replicas in the federation ReplicaSet


Actual results:
1. 
clusterfed (federation control panel hosted, context=qwangfed)
cluster2 (context=f2)
cluster3 (context=f3)


3. 
<Scenario 1: If federation control panel hosted cluster join into the federartion>
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get clusters --context=qwangfed
NAME         STATUS    AGE
cluster2     Ready     1d
cluster3     Ready     1d
clusterfed   Ready     1d

replicaset=3: 
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get replicaset -n qwangtest --context=qwangfed
NAME       DESIRED   CURRENT   READY     AGE
frontend   3         3         3         19m
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get replicaset -n qwangtest --context=f2
NAME       DESIRED   CURRENT   READY     AGE
frontend   1         1         1         19m
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get replicaset -n qwangtest --context=f3
NAME       DESIRED   CURRENT   READY     AGE
frontend   1         1         1         19m

replicaset=4: clusterfed(4), cluster2(2), cluster1(1)
replicaset=5: clusterfed(5), cluster2(2), cluster1(1)
replicaset=6: clusterfed(6), cluster2(2), cluster1(2)
replicaset=7: clusterfed(7), cluster2(3), cluster1(2)
replicaset=8: clusterfed(8), cluster2(3), cluster1(2)
replicaset=9: clusterfed(9), cluster2(3), cluster1(3)


<Scenario 2: If federation control panel hosted cluster doesn't join into the federartion>, the following are desired.
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get clusters --context=qwangfed
NAME         STATUS    AGE
cluster2     Ready     1d
cluster3     Ready     1d

replicaset=3: 
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get replicaset -n qwangtest --context=qwangfed
NAME       DESIRED   CURRENT   READY     AGE
frontend   3         3         3         48m
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get replicaset -n qwangtest --context=f2
NAME       DESIRED   CURRENT   READY     AGE
frontend   3         3         3         48m
[root@preserve-qe-qwang-1114-master-etcd-1 ~]# oc get replicaset -n qwangtest --context=f3
NAME       DESIRED   CURRENT   READY     AGE
frontend   0         0         0         48m

replicaset=4: clusterfed(4), cluster2(3), cluster1(1)
replicaset=5: clusterfed(5), cluster2(3), cluster1(2)
replicaset=5: clusterfed(6), cluster2(3), cluster1(3)


Expected results:
3. Since the federation control plane has no nodes, it cannot run pods, so even if it joined as a federated cluster, it should not take into the assignment of ReplicaSet. The behavior of Scenario 1 should be the same with Scenario 2.


Additional info:

Comment 1 Maru Newby 2017-11-17 17:23:40 UTC
Stop testing with the federation control plane joined as a member cluster.  Any behavior you experience in this configuration is not a bug - it is a result of an unsupported configuration.


Note You need to log in before you can comment on or make changes to this bug.