Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514382 - [guest-agent]Still can write to freezed file system after run "{ "execute": "guest-fsfreeze-freeze"}" cmd.
Summary: [guest-agent]Still can write to freezed file system after run "{ "execute": "...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.5
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Sameeh Jubran
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 09:33 UTC by xiagao
Modified: 2018-04-10 06:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 06:31:38 UTC


Attachments (Terms of Use)
event-8194 (deleted)
2017-11-17 09:36 UTC, xiagao
no flags Details
event-12293 (deleted)
2017-11-17 09:36 UTC, xiagao
no flags Details
event-12340 (deleted)
2017-11-17 09:37 UTC, xiagao
no flags Details
event-system (deleted)
2017-11-17 09:37 UTC, xiagao
no flags Details
event-8194-2 (deleted)
2017-11-20 03:25 UTC, xiagao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0657 None None None 2018-04-10 06:32:59 UTC

Description xiagao 2017-11-17 09:33:40 UTC
Description of problem:
Guest file system can't be frozen when running {"execute":"guest-fsfreeze-freeze"}

Version-Release number of selected component (if applicable):
qemu-ga-win-2.9.2-2.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Boot up win2008-32 guest.
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga -device virtserialport,bus=virtio-serial0.0,chardev=qga,name=org.qemu.guest_agent.0 \
-drive file=143-2008-qga.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \

2.Install virtio-serial driver, qemu-ga-win msi, python2.6 64bit inside guest.

3.Send some commands via guest agent. 
(On host)
# nc -U /tmp/qga.sock 
{"execute":"guest-ping"}
{"return": {}}

4. Run the following script inside guest:
# cat test.py 
import time
result = open("C:\\time.txt", "w")
while 1:
    result.write("%s\n\r" % time.ctime())
    result.flush()
    time.sleep(1)

C:\> test.py (run inside guest)

5. Freeze guest:

Freeze for more than 10s and then thaw it with guest agent command.

{"execute":"guest-fsfreeze-freeze"}
{"return": 1}
{"execute":"guest-fsfreeze-thaw"}
{"error": {"class": "GenericError", "desc": "couldn't hold writes: fsfreeze is limited up to 10 seconds: "}}

6. Check "C:\time.txt" file inside guest.

Actual results:
Time is always continous.

Fri Nov 17 17:01:12 2017
Fri Nov 17 17:01:13 2014
Fri Nov 17 17:01:14 2014
Fri Nov 17 17:01:15 2014
Fri Nov 17 17:01:16 2014
Fri Nov 17 17:01:17 2014
Fri Nov 17 17:01:18 2014
Fri Nov 17 17:01:19 2014 
Fri Nov 17 17:01:20 2014
Fri Nov 17 17:01:21 2014
Fri Nov 17 17:01:22 2014
Fri Nov 17 17:01:23 2014
Fri Nov 17 17:01:24 2014
Fri Nov 17 17:01:25 2014
Fri Nov 17 17:01:26 2014
Fri Nov 17 17:01:27 2014
Fri Nov 17 17:01:28 2014
Fri Nov 17 17:01:29 2014
Fri Nov 17 17:01:30 2014
Fri Nov 17 17:01:31 2014
Fri Nov 17 17:01:32 2014
Fri Nov 17 17:01:33 2014
Fri Nov 17 17:01:34 2014
Fri Nov 17 17:01:35 2014

Expected results:
Time should be not continous for about 10s .

Additional info:
1)qemu-ga-win-7.4.5-1 not hit this issue.
2)VSS service is running.

3)check event viewer
ERROR Event ID: 12340 and 8194 in "Application"
ERROR Event ID: 8 in "System"

Comment 2 xiagao 2017-11-17 09:36:11 UTC
Created attachment 1354051 [details]
event-8194

Comment 3 xiagao 2017-11-17 09:36:43 UTC
Created attachment 1354052 [details]
event-12293

Comment 4 xiagao 2017-11-17 09:37:20 UTC
Created attachment 1354053 [details]
event-12340

Comment 5 xiagao 2017-11-17 09:37:55 UTC
Created attachment 1354054 [details]
event-system

Comment 7 Sameeh Jubran 2017-11-19 16:10:34 UTC
(In reply to xiagao from comment #0)
> Description of problem:
> Guest file system can't be frozen when running
> {"execute":"guest-fsfreeze-freeze"}
> 
> Version-Release number of selected component (if applicable):
> qemu-ga-win-2.9.2-2.el7ev.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1.Boot up win2008-32 guest.
> -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev
> socket,path=/tmp/qga.sock,server,nowait,id=qga -device
> virtserialport,bus=virtio-serial0.0,chardev=qga,name=org.qemu.guest_agent.0 \
> -drive
> file=143-2008-qga.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,
> cache=none -device
> ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
> 
> 2.Install virtio-serial driver, qemu-ga-win msi, python2.6 64bit inside
> guest.
> 
> 3.Send some commands via guest agent. 
> (On host)
> # nc -U /tmp/qga.sock 
> {"execute":"guest-ping"}
> {"return": {}}
> 
> 4. Run the following script inside guest:
> # cat test.py 
> import time
> result = open("C:\\time.txt", "w")
> while 1:
>     result.write("%s\n\r" % time.ctime())
>     result.flush()
>     time.sleep(1)
> 
> C:\> test.py (run inside guest)
> 
> 5. Freeze guest:
> 
> Freeze for more than 10s and then thaw it with guest agent command.
> 
> {"execute":"guest-fsfreeze-freeze"}
> {"return": 1}
> {"execute":"guest-fsfreeze-thaw"}
> {"error": {"class": "GenericError", "desc": "couldn't hold writes: fsfreeze
> is limited up to 10 seconds: "}}
> 
> 6. Check "C:\time.txt" file inside guest.
> 
> Actual results:
> Time is always continous.
> 
> Fri Nov 17 17:01:12 2017
> Fri Nov 17 17:01:13 2014
> Fri Nov 17 17:01:14 2014
> Fri Nov 17 17:01:15 2014
> Fri Nov 17 17:01:16 2014
> Fri Nov 17 17:01:17 2014
> Fri Nov 17 17:01:18 2014
> Fri Nov 17 17:01:19 2014 
> Fri Nov 17 17:01:20 2014
> Fri Nov 17 17:01:21 2014
> Fri Nov 17 17:01:22 2014
> Fri Nov 17 17:01:23 2014
> Fri Nov 17 17:01:24 2014
> Fri Nov 17 17:01:25 2014
> Fri Nov 17 17:01:26 2014
> Fri Nov 17 17:01:27 2014
> Fri Nov 17 17:01:28 2014
> Fri Nov 17 17:01:29 2014
> Fri Nov 17 17:01:30 2014
> Fri Nov 17 17:01:31 2014
> Fri Nov 17 17:01:32 2014
> Fri Nov 17 17:01:33 2014
> Fri Nov 17 17:01:34 2014
> Fri Nov 17 17:01:35 2014

I don't think this means that the VSS doesn't work! Let me investigate that a bit.

> 
> Expected results:
> Time should be not continous for about 10s .
> 
> Additional info:
> 1)qemu-ga-win-7.4.5-1 not hit this issue.
> 2)VSS service is running.
> 
> 3)check event viewer
> ERROR Event ID: 12340 and 8194 in "Application"
> ERROR Event ID: 8 in "System"
The 8194 error is caused by lack of DCOM permission and should be resolved in future patches, check this BZ for more information:
https://bugzilla.redhat.com/show_bug.cgi?id=1444702

12340 is due to a generous timeout configured in qemu-ga. I 'll apply the relevant patch and post a new build soon.

Comment 9 xiagao 2017-11-20 03:24:27 UTC
(In reply to Sameeh Jubran from comment #8)
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14584177


Test in this version.Steps like comment 0.
Still hit this issue, after run { "execute": "guest-fsfreeze-freeze"}

1) time is continuous in time.txt
2)check event viewer
ERROR Event ID: 8194 in "Application"

Comment 10 xiagao 2017-11-20 03:25:01 UTC
Created attachment 1355462 [details]
event-8194-2

Comment 11 xiagao 2017-11-20 04:32:47 UTC
(In reply to xiagao from comment #9)
> (In reply to Sameeh Jubran from comment #8)
> > https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14584177
> 
> 
> Test in this version.Steps like comment 0.
> Still hit this issue, after run { "execute": "guest-fsfreeze-freeze"}
> 
> 1) time is continuous in time.txt
> 2)check event viewer
> ERROR Event ID: 8194 in "Application"

Correct this result.

1) Time is still continuous in time.txt.

2) There is no 12340 Event Id in event viewer.

Comment 12 Sameeh Jubran 2017-11-20 15:21:25 UTC
I played with the issue with the time a bit and found a very odd behavior, sometimes It did leave a gap and some times it did not. Can you reboot the VM and and immediately after boot try and reproduce this?

Comment 13 xiagao 2017-11-22 08:27:34 UTC
(In reply to Sameeh Jubran from comment #12)
> I played with the issue with the time a bit and found a very odd behavior,
> sometimes It did leave a gap and some times it did not. Can you reboot the
> VM and and immediately after boot try and reproduce this?

Yes, It can leave a gap only once after reboot the VM.

Comment 16 Sameeh Jubran 2017-11-27 09:02:56 UTC
mingw-qemu-ga-win v2.9.3 build is ready:

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14628546

Comment 17 Peixiu Hou 2017-11-29 06:36:08 UTC
Tested with the mingw-qemu-ga-win v2.9.3 build:

1. Tested on win2016 guest, cannot reproduced this bug.
2. Tested on win2008-32, also can reproduced this bug, time also is continuously.

Steps as comment#0.

Best Regards~
Peixiu Hou

Comment 18 Sameeh Jubran 2017-11-30 08:03:57 UTC
(In reply to Peixiu Hou from comment #17)
> Tested with the mingw-qemu-ga-win v2.9.3 build:
> 
> 1. Tested on win2016 guest, cannot reproduced this bug.
> 2. Tested on win2008-32, also can reproduced this bug, time also is
> continuously.
Did you try to reproduce immediately after boot?
> 
> Steps as comment#0.
> 
> Best Regards~
> Peixiu Hou

Comment 19 Peixiu Hou 2017-11-30 10:06:53 UTC
(In reply to Sameeh Jubran from comment #18)
> (In reply to Peixiu Hou from comment #17)
> > Tested with the mingw-qemu-ga-win v2.9.3 build:
> > 
> > 1. Tested on win2016 guest, cannot reproduced this bug.
> > 2. Tested on win2008-32, also can reproduced this bug, time also is
> > continuously.
> Did you try to reproduce immediately after boot?
>
Hi, yes, I tried to reproduce immediately after guest boot up, and I also test again, same result~

1. Boot guest up with qemu cmd:
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device virtserialport,bus=virtio-serial0.0,chardev=qga0,name=org.qemu.guest_agent.0

2. Steps as comment#0, for step 5, 
{"execute":"guest-fsfreeze-freeze"}
{"return": 2}
{"execute":"guest-fsfreeze-thaw"}
{"return": 2}

thaw guest will not report error message like before:
{"error": {"class": "GenericError", "desc": "couldn't hold writes: fsfreeze is limited up to 10 seconds: "}}

Best Regards~
Peixiu Hou

Comment 20 Sameeh Jubran 2017-11-30 10:40:42 UTC
(In reply to Peixiu Hou from comment #19)
> (In reply to Sameeh Jubran from comment #18)
> > (In reply to Peixiu Hou from comment #17)
> > > Tested with the mingw-qemu-ga-win v2.9.3 build:
> > > 
> > > 1. Tested on win2016 guest, cannot reproduced this bug.
> > > 2. Tested on win2008-32, also can reproduced this bug, time also is
> > > continuously.
> > Did you try to reproduce immediately after boot?
> >
> Hi, yes, I tried to reproduce immediately after guest boot up, and I also
> test again, same result~
> 
> 1. Boot guest up with qemu cmd:
> -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev
> socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device
> virtserialport,bus=virtio-serial0.0,chardev=qga0,name=org.qemu.guest_agent.0
> 
> 2. Steps as comment#0, for step 5, 
> {"execute":"guest-fsfreeze-freeze"}
> {"return": 2}
> {"execute":"guest-fsfreeze-thaw"}
> {"return": 2}
> 
> thaw guest will not report error message like before:
> {"error": {"class": "GenericError", "desc": "couldn't hold writes: fsfreeze
> is limited up to 10 seconds: "}}
> 
> Best Regards~
> Peixiu Hou

With the stable build, can you reproduce always? Try to reproduce for like 10 times, I think you shouldn't be able to successfully leave a gap after several attempts. (Don't reboot in between attempts)

Comment 21 Peixiu Hou 2017-12-01 10:02:46 UTC
(In reply to Sameeh Jubran from comment #20)
> (In reply to Peixiu Hou from comment #19)
> > (In reply to Sameeh Jubran from comment #18)
> > > (In reply to Peixiu Hou from comment #17)
> > > > Tested with the mingw-qemu-ga-win v2.9.3 build:
> > > > 
> > > > 1. Tested on win2016 guest, cannot reproduced this bug.
> > > > 2. Tested on win2008-32, also can reproduced this bug, time also is
> > > > continuously.
> > > Did you try to reproduce immediately after boot?
> > >
> > Hi, yes, I tried to reproduce immediately after guest boot up, and I also
> > test again, same result~
> > 
> > 1. Boot guest up with qemu cmd:
> > -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev
> > socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device
> > virtserialport,bus=virtio-serial0.0,chardev=qga0,name=org.qemu.guest_agent.0
> > 
> > 2. Steps as comment#0, for step 5, 
> > {"execute":"guest-fsfreeze-freeze"}
> > {"return": 2}
> > {"execute":"guest-fsfreeze-thaw"}
> > {"return": 2}
> > 
> > thaw guest will not report error message like before:
> > {"error": {"class": "GenericError", "desc": "couldn't hold writes: fsfreeze
> > is limited up to 10 seconds: "}}
> > 
> > Best Regards~
> > Peixiu Hou
> 
> With the stable build, can you reproduce always? Try to reproduce for like
> 10 times, I think you shouldn't be able to successfully leave a gap after
> several attempts. (Don't reboot in between attempts)

Hi, 
I tried to test this case 10 times, reproduced this issue 8 times, there are 2 times the time can be paused, one time paused 8 seconds, one time paused 7 seconds.

Time details as follows:
===========================
Fri Dec 01 09:34:17 2017
Fri Dec 01 09:34:18 2017
Fri Dec 01 09:34:26 2017
Fri Dec 01 09:34:27 2017
===========================
===========================
Fri Dec 01 09:37:33 2017
Fri Dec 01 09:37:34 2017
Fri Dec 01 09:37:42 2017
Fri Dec 01 09:37:43 2017
===========================

Best Regards~
Peixiu Hou

Comment 22 Sameeh Jubran 2017-12-03 17:18:54 UTC
Since this can be reproduced in earlier versions of qemu-ga-win as well this is not a regression, and it seems to be reproduced in Win2008-32 only, can you confirm this?

Comment 23 lijin 2017-12-04 02:54:08 UTC
(In reply to Sameeh Jubran from comment #22)
> Since this can be reproduced in earlier versions of qemu-ga-win as well this
> is not a regression, and it seems to be reproduced in Win2008-32 only, can
> you confirm this?

Yes, the latest qemu-ga has fixed this issue on non-win2008 guests.
Issue on win2008 is not a regression bug.

So remove regression keyword.

Comment 24 lijin 2017-12-04 03:33:30 UTC
bz1409724 tracks the windows2008 issue, so let's verified this bug according to comment#17

Comment 26 errata-xmlrpc 2018-04-10 06:31:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0657


Note You need to log in before you can comment on or make changes to this bug.