Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514345 - Flash Error message " Infrastructure Provider no longer exists " displays when refresh or remove provider
Summary: Flash Error message " Infrastructure Provider no longer exists " displays whe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Zita Nemeckova
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
: 1514421 1514557 1514893 1517789 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 07:38 UTC by Niyaz Akhtar Ansari
Modified: 2018-03-26 16:08 UTC (History)
14 users (show)

Fixed In Version: 5.9.0.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 15:21:52 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
error (deleted)
2017-11-17 07:38 UTC, Niyaz Akhtar Ansari
no flags Details

Description Niyaz Akhtar Ansari 2017-11-17 07:38:46 UTC
Created attachment 1354044 [details]
error

Description of problem:


Version-Release number of selected component (if applicable):
Version 5.9.0.9.20171115202245_7429f75 

How reproducible:
100%

Steps to Reproduce:
1.Add Infra provider(Vsphere)
2.Go to Compute->Infrastructure->Providers
3.Select Provider
4.Click on "Refresh Relationship and power state" button or try to remove provider from configuration button

Actual results:
Wrong flash message displays "Infrastructure Provider no longer exists "
Unable to remove provider

Expected results:
no error

Additional info:

Comment 2 Adam Grare 2017-11-17 15:04:32 UTC
I saw the same thing, any actions taken from the Infrastructure Providers screen result in that error.  Clicking on the provider and doing the same actions on the specific provider work fine.

Comment 3 Dan Clarizio 2017-11-17 15:46:39 UTC
*** Bug 1514421 has been marked as a duplicate of this bug. ***

Comment 4 Dan Clarizio 2017-11-17 15:51:14 UTC
So I tested as well and see the same results as Adam.  On the list view screen, when checking one of the providers and selecting the Refresh Relationships and Power States button from the Configuration button group, receive the "Infrastructure Provider no longer exists" flash message.  Doing the same from an individual provider summary screen, it works properly.

Zita, this may be due to GTL refactoring, so ping MartinP if you need assistance.

Comment 5 Niyaz Akhtar Ansari 2017-11-18 08:34:42 UTC
This error is happening probably with every providers.

Comment 7 Zita Nemeckova 2017-11-23 10:17:39 UTC
*** Bug 1514557 has been marked as a duplicate of this bug. ***

Comment 8 Ari Zellner 2017-11-23 14:49:51 UTC
*** Bug 1514893 has been marked as a duplicate of this bug. ***

Comment 10 Ilanit Stein 2017-11-27 16:48:40 UTC
*** Bug 1517789 has been marked as a duplicate of this bug. ***

Comment 11 Tasos Papaioannou 2017-11-28 19:55:05 UTC
Verified on 5.9.0.11.


Note You need to log in before you can comment on or make changes to this bug.