Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514334 - [Regression] Cannot retire VM
Summary: [Regression] Cannot retire VM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Hilda Stastna
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
: 1515320 1515745 1515807 1516221 1516381 1516419 1516480 1516657 1516858 1516869 1517214 (view as bug list)
Depends On:
Blocks: 1517842
TreeView+ depends on / blocked
 
Reported: 2017-11-17 06:44 UTC by Vatsal Parekh
Modified: 2018-06-21 21:01 UTC (History)
15 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517842 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:01:02 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
recording (deleted)
2017-11-17 06:44 UTC, Vatsal Parekh
no flags Details

Description Vatsal Parekh 2017-11-17 06:44:41 UTC
Created attachment 1354033 [details]
recording

Description of problem:
Selecting VMs from checkbox in all VMs view and retiring them shows the error 'No items were selected for Retirement'

production.log:
----] I, [2017-11-17T01:40:28.467951 #13258:1434d3c]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-b9b23b73c72d/app/views/layouts/_x_adv_searchbox.html.haml (0.4ms)
[----] I, [2017-11-17T01:40:28.479945 #13258:1434d3c]  INFO -- : Completed 200 OK in 98ms (Views: 9.7ms | ActiveRecord: 3.7ms)
[----] I, [2017-11-17T01:40:29.046441 #13258:1434abc]  INFO -- : Started POST "/vm_infra/report_data" for 127.0.0.1 at 2017-11-17 01:40:29 -0500
[----] I, [2017-11-17T01:40:29.050467 #13258:1434abc]  INFO -- : Processing by VmInfraController#report_data as HTML
[----] I, [2017-11-17T01:40:29.050610 #13258:1434abc]  INFO -- :   Parameters: {"model_name"=>"VmOrTemplate", "model"=>"VmOrTemplate", "active_tree"=>"vandt_tree", "explorer"=>true, "additional_options"=>{"named_scope"=>["with_ems"], "gtl_dbname"=>nil, "model"=>"VmOrTemplate", "match_via_descendants"=>nil, "parent_id"=>2, "parent_class_name"=>"ManageIQ::Providers::Redhat::InfraManager", "parent_method"=>nil, "association"=>"all_vms_and_templates", "view_suffix"=>nil, "row_button"=>nil, "listicon"=>nil, "embedded"=>nil, "showlinks"=>nil, "policy_sim"=>nil}, "vm"=>{}}
[----] I, [2017-11-17T01:40:29.696029 #13258:1434abc]  INFO -- : Completed 200 OK in 645ms (Views: 11.3ms | ActiveRecord: 41.2ms)
[----] I, [2017-11-17T01:40:40.382412 #13258:14335f4]  INFO -- : Started POST "/vm_infra/x_button?pressed=vm_retire_now" for 127.0.0.1 at 2017-11-17 01:40:40 -0500
[----] I, [2017-11-17T01:40:40.384963 #13258:14335f4]  INFO -- : Processing by VmInfraController#x_button as JS
[----] I, [2017-11-17T01:40:40.385033 #13258:14335f4]  INFO -- :   Parameters: {"miq_grid_checks"=>"91", "pressed"=>"vm_retire_now"}
[----] I, [2017-11-17T01:40:40.457484 #13258:14335f4]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-b9b23b73c72d/app/views/layouts/_flash_msg.html.haml (0.1ms)
[----] I, [2017-11-17T01:40:40.457772 #13258:14335f4]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-b9b23b73c72d/app/views/layouts/_info_msg.html.haml (0.0ms)
[----] I, [2017-11-17T01:40:40.458496 #13258:14335f4]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-b9b23b73c72d/app/views/layouts/angular/_gtl.html.haml (1.2ms)
[----] I, [2017-11-17T01:40:40.458621 #13258:14335f4]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-b9b23b73c72d/app/views/layouts/_x_gtl.html.haml (1.4ms)
[----] I, [2017-11-17T01:40:40.459346 #13258:14335f4]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-b9b23b73c72d/app/views/layouts/_x_adv_searchbox.html.haml (0.4ms)
[----] I, [2017-11-17T01:40:40.469647 #13258:14335f4]  INFO -- : Completed 200 OK in 84ms (Views: 7.8ms | ActiveRecord: 3.8ms)
[----] I, [2017-11-17T01:40:41.044782 #13258:14321b8]  INFO -- : Started POST "/vm_infra/report_data" for 127.0.0.1 at 2017-11-17 01:40:41 -0500
[----] I, [2017-11-17T01:40:41.049807 #13258:14321b8]  INFO -- : Processing by VmInfraController#report_data as HTML
[----] I, [2017-11-17T01:40:41.050004 #13258:14321b8]  INFO -- :   Parameters: {"model_name"=>"VmOrTemplate", "model"=>"VmOrTemplate", "active_tree"=>"vandt_tree", "explorer"=>true, "additional_options"=>{"named_scope"=>["with_ems"], "gtl_dbname"=>nil, "model"=>"VmOrTemplate", "match_via_descendants"=>nil, "parent_id"=>2, "parent_class_name"=>"ManageIQ::Providers::Redhat::InfraManager", "parent_method"=>nil, "association"=>"all_vms_and_templates", "view_suffix"=>nil, "row_button"=>nil, "listicon"=>nil, "embedded"=>nil, "showlinks"=>nil, "policy_sim"=>nil}, "vm"=>{}}
[----] I, [2017-11-17T01:40:41.682650 #13258:14321b8]  INFO -- : Completed 200 OK in 632ms (Views: 12.7ms | ActiveRecord: 43.6ms)

Version-Release number of selected component (if applicable):
Version 5.9.0.9.20171115202245_7429f75

How reproducible:


Steps to Reproduce:
1.Compute->Infra-VMs
2.Select and retire VMs
3.

Actual results:
throws the mentioned error

Expected results:
Should retire the VM

Additional info:
See the attached video recording

Comment 3 Martin Povolny 2017-11-21 12:39:13 UTC
*** Bug 1515807 has been marked as a duplicate of this bug. ***

Comment 4 Martin Povolny 2017-11-21 12:43:01 UTC
*** Bug 1515320 has been marked as a duplicate of this bug. ***

Comment 5 Hilda Stastna 2017-11-21 15:14:57 UTC
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/2784

Comment 6 Hilda Stastna 2017-11-22 13:32:09 UTC
*** Bug 1515745 has been marked as a duplicate of this bug. ***

Comment 7 Dan Clarizio 2017-11-22 16:48:03 UTC
*** Bug 1516381 has been marked as a duplicate of this bug. ***

Comment 8 Hilda Stastna 2017-11-23 12:32:50 UTC
*** Bug 1516221 has been marked as a duplicate of this bug. ***

Comment 9 Hilda Stastna 2017-11-23 16:45:14 UTC
*** Bug 1516657 has been marked as a duplicate of this bug. ***

Comment 10 Hilda Stastna 2017-11-23 16:54:05 UTC
*** Bug 1516869 has been marked as a duplicate of this bug. ***

Comment 11 Hilda Stastna 2017-11-23 17:33:02 UTC
*** Bug 1516480 has been marked as a duplicate of this bug. ***

Comment 12 Hilda Stastna 2017-11-24 16:40:22 UTC
*** Bug 1516419 has been marked as a duplicate of this bug. ***

Comment 13 Hilda Stastna 2017-11-27 10:17:36 UTC
*** Bug 1516858 has been marked as a duplicate of this bug. ***

Comment 14 Dávid Halász 2017-11-27 14:18:31 UTC
*** Bug 1517214 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.