Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514331 - jenkins slave passes tests even though they fail on master locally
Summary: jenkins slave passes tests even though they fail on master locally
Keywords:
Status: CLOSED DUPLICATE of bug 1509335
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 06:04 UTC by Ravishankar N
Modified: 2017-11-29 13:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-17 07:05:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-11-17 06:04:47 UTC
Description of problem:
Please see http://lists.gluster.org/pipermail/maintainers/2017-November/003617.html


1.tests/bugs/cli/bug-1169302.t
2.tests/bugs/distribute/bug-1247563.t 

Both are failing, Nithya looked into the 2nd one and is working on the fix via BZ 1514329. I'm sure the 1st one will fail too if you try to run it on your local setup.

Comment 1 Nigel Babu 2017-11-17 07:04:17 UTC
From working with Nithya over the last couple of days to debug this, it appears that us running regressions on Centos 6 has caught up with us. We will need to upgrade to newer versions to hit these failures. I can reliably reproduce both of these on latest CentOS 7. The case may be that we have newer dependencies (in the second case, XFS changed behavior).

From an infra point of view, we'll take the following actions:
We've been working on moving our regression machines into the cage. We already have a bunch of new machines ready for import into the cage. Those machines are already setup with Centos 7. I'll get regression-test-burn-in to run on those nodes. This will give us an environment where these tests can fail consistently and therefore can be fixed.

Once they're fixed, we'll cycle our regression infra to be completely Centos 7. We already run smoke on Centos 7 ever since it moved to the cage.

From a dev point of view, we'll need to fix these tests or fix the underlying code because it's no longer behaving as it should.

Comment 2 Nigel Babu 2017-11-17 07:05:19 UTC
I'm going to dupe this infra bug to our bug to activate the Centos 7 nodes, since that will solve the problem from the infra side of things.

*** This bug has been marked as a duplicate of bug 1509335 ***

Comment 3 Worker Ant 2017-11-29 13:01:53 UTC
REVIEW: https://review.gluster.org/18893 (tests: Fix a broken test case) posted (#1) for review on master by Poornima G


Note You need to log in before you can comment on or make changes to this bug.