Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514329 - bug-1247563.t is failing on master
Summary: bug-1247563.t is failing on master
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1515042 1515045 1515051
TreeView+ depends on / blocked
 
Reported: 2017-11-17 05:58 UTC by Ravishankar N
Modified: 2018-03-15 11:21 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1515042 1515045 1515051 (view as bug list)
Environment:
Last Closed: 2018-03-15 11:21:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-11-17 05:58:38 UTC
Description of problem:
Please see http://lists.gluster.org/pipermail/maintainers/2017-November/003617.html

Comment 1 Nithya Balachandran 2017-11-17 06:10:27 UTC
On running prove -fv tests/bugs/distribute/bug-1247563.t:

On my system:

 
getfacl: Removing leading '/' from absolute path names
# file: bricks/brick1/backends/patchy3/dir1/FILE2
security.selinux=0x756e636f6e66696e65645f753a6f626a6563745f723a756e6c6162656c65645f743a733000
trusted.SGI_ACL_FILE=0x0000000500000001ffffffff0006000000000002000000000007000000000004ffffffff0004000000000010ffffffff0007000000000020ffffffff00040000
trusted.gfid=0xb597bb42e7bb4b4a91e464e1b536d6d7
trusted.gfid2path.7de510351b1c8e08=0x65393039386432382d346166612d343030372d396230322d3066316463313961666337312f46494c4532
trusted.glusterfs.dht.linkto=0x7061746368792d636c69656e742d3100
trusted.glusterfs.selinux=0x756e636f6e66696e65645f753a6f626a6563745f723a756e6c6162656c65645f743a733000


On Ravi's system where the issue is reproducible:


[root@ravi1 backends]# getfattr -e hex  -m . -d   ./patchy3/dir1/FILE2 ; getfacl ./patchy3/dir1/FILE2 
# file: patchy3/dir1/FILE2
security.selinux=0x756e636f6e66696e65645f753a6f626a6563745f723a64656661756c745f743a733000
system.posix_acl_access=0x0200000001000600ffffffff020007000000000004000400ffffffff10000700ffffffff20000400ffffffff
trusted.SGI_ACL_FILE=0x0000000500000001ffffffff0006000000000002000000000007000000000004ffffffff0004000000000010ffffffff0007000000000020ffffffff00040000
trusted.gfid=0x4fa885df7204439293c32569310ee747
trusted.gfid2path.9db1d06b9f2b8b0a=0x30623737313037312d323435622d343134372d396233302d3463326466383363633639642f46494c4532
trusted.glusterfs.dht.linkto=0x7061746368792d636c69656e742d3100
trusted.glusterfs.selinux=0x756e636f6e66696e65645f753a6f626a6563745f723a64656661756c745f743a733000


There is an ACL (system.posix_acl_access)set on the file which causes the following test to fail.

#The linkto file should not have any posix acls set                                                                                                                  
COUNT=`getfacl $FPATH2 |grep -c "user:root:rwx"`                                   
EXPECT "0" echo $COUNT 


From Google:

..."the XFS filesystem which stores ACLs  as trusted.SGI_ACL_FILE extended  attribute and generates system.posix_acl_access on the fly."


Assuming that this is not an attribute the user space should set on a file, I am stripping this out from the results of the listxattr call in dht_migrate_file.

Comment 2 Worker Ant 2017-11-17 06:45:31 UTC
REVIEW: https://review.gluster.org/18794 (cluster/dht: Don't set ACLs on linkto file) posted (#1) for review on master by N Balachandran

Comment 3 Worker Ant 2017-11-19 03:06:43 UTC
COMMIT: https://review.gluster.org/18794 committed in master by \"N Balachandran\" <nbalacha@redhat.com> with a commit message- cluster/dht: Don't set ACLs on linkto file

The trusted.SGI_ACL_FILE appears to set posix
ACLs on the linkto file that is a target of
file migration. This can mess up file permissions
and cause linkto identification to fail.
Now we remove all ACL xattrs from the results of
the listxattr call on the source before setting them
on the target.

Change-Id: I56802dbaed783a16e3fb90f59f4ce849f8a4a9b4
BUG: 1514329
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 4 Shyamsundar 2018-03-15 11:21:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.