Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514303 - QEMU Guest Agent VSS Provider service is being installed with startup type: Automatic
Summary: QEMU Guest Agent VSS Provider service is being installed with startup type: A...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.5
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Sameeh Jubran
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 02:46 UTC by xiagao
Modified: 2018-04-10 06:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 06:31:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0657 None None None 2018-04-10 06:32:59 UTC

Description xiagao 2017-11-17 02:46:06 UTC
Description of problem:
Install the lastest qemu-ga-win.msi and check that QEMU Guest Agent VSS Provider service is being installed with startup type: Automatic.
From Bug 1286672 - Insure that Windows Qemu Guest Agent VSS Provider is started after installation, it should be Manual.


Version-Release number of selected component (if applicable):
mingw-qemu-ga-win-2.9.2-2.el7ev
qemu-kvm-rhev-2.10.0-6.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot up win8-32 guest
2.install vioser driver and qemu-ga-x.msi,check VSS startup type

Actual results:
startup type: Automatic

Expected results:
startup type: Manual

issue {"execute":"guest-fsfreeze-freeze"} in host and create snapshot, check VSS status is started
issue  {"execute":"guest-fsfreeze-thaw"}in host,check VSS status is null.

Additional info:
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga -device virtserialport,bus=virtio-serial0.0,chardev=qga,name=org.qemu.guest_agent.0 \
-drive file=143BLNWIN832-du.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \

Comment 2 Sameeh Jubran 2017-11-19 16:34:15 UTC
Please test this version:

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14584177

Comment 3 xiagao 2017-11-20 03:35:28 UTC
(In reply to Sameeh Jubran from comment #2)
> Please test this version:
> 
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14584177

Tested in this version, steps like comment 0.
The result is:
1) startup type: Manual   -->Expected

2) issue {"execute":"guest-fsfreeze-freeze"} in host and create snapshot, check VSS status is started  -->Expected

3) issue  {"execute":"guest-fsfreeze-thaw"} in host,check VSS service's status is still started.     -----> It should be null. 

So this bug is not fixed.

Comment 4 Sameeh Jubran 2017-11-20 15:17:25 UTC
I think this should be resolved in this build:

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14587298

What do you mean by "null status"?

Comment 5 xiagao 2017-11-21 02:08:05 UTC
(In reply to Sameeh Jubran from comment #4)
> I think this should be resolved in this build:
> 
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14587298
> 
> What do you mean by "null status"?

I think VSS service should be stop status after executing {"execute":"guest-fsfreeze-thaw"} in host.

Comment 6 xiagao 2017-11-21 02:17:30 UTC
(In reply to xiagao from comment #5)
> (In reply to Sameeh Jubran from comment #4)
> > I think this should be resolved in this build:
> > 
> > https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14587298
> > 
> > What do you mean by "null status"?
> 
> I think VSS service should be stop status after executing
> {"execute":"guest-fsfreeze-thaw"} in host.

I mean VSS Service status should be empty rather than "started" in guest after issuing  {"execute":"guest-fsfreeze-thaw"}.

Comment 7 xiagao 2017-11-21 02:40:10 UTC
Test with the latest build you provided.
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14587298

The result is:
1) startup type: Manual   -->Expected

2) issue {"execute":"guest-fsfreeze-freeze"} in host and create snapshot, check VSS status is started  -->Expected

3) issue  {"execute":"guest-fsfreeze-thaw"} in host,check VSS service's status is empty.     -----> Expected. 

So this bug is fixed.

I will verify this bug in an official build.

Comment 8 Sameeh Jubran 2017-11-27 09:03:22 UTC
mingw-qemu-ga-win v2.9.3 build is ready:

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14628546

Comment 9 Yu Wang 2017-11-28 03:20:44 UTC
reproduce with previous version, and verified with mingw-qemu-ga-win v2.9.3

steps as comment#0

So, this bug has been fixed

version:
qemu-ga-win-2.9.3-2.el7ev.noarch
qemu-kvm-rhev-2.10.0-7.el7.x86_64


Thanks
Yu Wang

Comment 11 errata-xmlrpc 2018-04-10 06:31:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0657


Note You need to log in before you can comment on or make changes to this bug.