Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514296 - [Version conflict] Cannot upgrade from Fedora 26
Summary: [Version conflict] Cannot upgrade from Fedora 26
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: catfish
Version: rawhide
Hardware: noarch
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-17 01:24 UTC by Christopher Meng
Modified: 2017-11-17 15:27 UTC (History)
3 users (show)

Fixed In Version: catfish-1.4.2-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-17 15:20:56 UTC


Attachments (Terms of Use)

Description Christopher Meng 2017-11-17 01:24:59 UTC
I've noticed this bug since months ago but when I come back it still abides here.

# dnf update catfish* 1>/dev/null

 Problem: cannot install both catfish-common-1.4.2-2.fc28.3.noarch and catfish-common-1.4.2-2.fc26.2.noarch
  - package catfish-1.4.2-2.fc26.2.noarch requires catfish-common = 1.4.2-2.fc26.2, but none of the providers can be installed
  - cannot install the best update candidate for package catfish-common-1.4.2-2.fc26.2.noarch
  - problem with installed package catfish-1.4.2-2.fc26.2.noarch

Please bump the version to 1.4.2-3.fc28 instead to solve it.

Comment 1 Mamoru TASAKA 2017-11-17 01:48:47 UTC
[mtasaka@localhost ~]$ koji latest-pkg f28-build catfish
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
catfish-1.4.2-2.fc28.3                    f28                   zbyszek
[mtasaka@localhost ~]$ koji latest-pkg f26-build catfish
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
catfish-1.4.2-2.fc26.2                    f26                   releng
[mtasaka@localhost ~]$ rpmdev-vercmp 1.4.2-2.fc28.3 1.4.2-2.fc26.2
1.4.2-2.fc28.3 > 1.4.2-2.fc26.2

So this is not a bug.

Comment 2 Mamoru TASAKA 2017-11-17 02:15:41 UTC
(Actually dnf does not show verbose dependency chain report, so it is hard to analyze dependency issue :( , however anyway at least version upgrade path is correct here)

Comment 4 Mamoru TASAKA 2017-11-17 15:20:56 UTC
* Sat Nov 18 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.4.2-3
- Fix up python2 namespace script bug manually

Comment 5 Zbigniew Jędrzejewski-Szmek 2017-11-17 15:27:58 UTC
Thanks.


Note You need to log in before you can comment on or make changes to this bug.