Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514261 - Unable to create image from url with ssl after updating glance
Summary: Unable to create image from url with ssl after updating glance
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Cyril Roelandt
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 22:55 UTC by nalmond
Modified: 2018-01-24 13:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-01 19:17:17 UTC
tshefi: automate_bug-


Attachments (Terms of Use)

Description nalmond 2017-11-16 22:55:44 UTC
Description of problem:
Attempting to create a glance image that is hosted on a remote server via https fails. http works without issue

Version-Release number of selected component (if applicable):
openstack-glance-11.0.1-7.el7ost.noarch

How reproducible:
Consistently in this environment, was working prior to a minor update

Steps to Reproduce:
1. Update to openstack-glance-11.0.1-7.el7ost.noarch
2. openstack image create test --container-format bare --disk-format qcow2 --copy-from https://<ip>/path/to/image --os-image-api-version 1

Actual results:
HTTPBadRequest: 400 Bad Request: The HTTP URL is invalid. (HTTP 400)

Expected results:
Image is created

Additional info:
Added 'https_insecure=true' to glance_store in /etc/glance/glance-api.conf, but this didn't help. Able to wget (with --no-check-certificate) the image to the controllers without issue.

Comment 4 nalmond 2017-12-01 19:17:17 UTC
There seems to be an issue with the ssl certificate on the remote webserver. After editing /etc/python/cert-verification.cfg such that 'verify=disable' on the controllers, the image was able to be created from the ssl webserver. I'm closing this as it does not appear to be a bug at this point.


Note You need to log in before you can comment on or make changes to this bug.