Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514250 - rhythmbox mozilla plugin crashes eclipse ide
Summary: rhythmbox mozilla plugin crashes eclipse ide
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 22:25 UTC by Gregory Lee Bartholomew
Modified: 2017-11-22 14:14 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 14:14:17 UTC


Attachments (Terms of Use)
JVM crash log 1 (deleted)
2017-11-17 14:30 UTC, Gregory Lee Bartholomew
no flags Details
JVM crash log 2 (deleted)
2017-11-17 14:30 UTC, Gregory Lee Bartholomew
no flags Details

Description Gregory Lee Bartholomew 2017-11-16 22:25:43 UTC
Description of problem:

Eclipse IDE crashes on startup with "java quit unexpectedly" reported in abrt.

Version-Release number of selected component (if applicable):

eclipse-jdt-4.7.1-6.fc26.noarch
rhythmbox.x86_64 3.4.1-3.fc26
java-1.8.0-openjdk-1.8.0.151-1.b12.fc26.x86_64

How reproducible:

Crashed on startup 9/10 times (started once but crashed shortly after startup with the same error).

Steps to Reproduce:

1. Try to launch eclipse ide from gnome

Actual results:

Slow startup and eventual crash

Expected results:


Additional info:

I just ran "sudo dnf remove rhythmbox" and eclipse seems to have started working properly.

Fairly vanilla install of Fedora 26 with all current updates (as of 11/16/17) other than having installed several supplemental packages using "dnf groupinstall ...".

output from dnf grouplist:

# dnf grouplist
...
Installed Groups:
   3D Printing
   Authoring and Publishing
   Books and Guides
   C Development Tools and Libraries
   Design Suite
   Development Tools
   Fedora Eclipse
   Editors
   Engineering and Scientific
   LibreOffice
   Office/Productivity
   Python Classroom
   Python Science
   Robotics
   Security Lab
   GNOME Desktop Environment
   Fonts
   Hardware Support
   Sound and Video
   System Tools

Comment 1 Alexander Kurtakov 2017-11-17 05:05:46 UTC
Can you provide the jvm crash log?

Comment 2 Gregory Lee Bartholomew 2017-11-17 14:30:10 UTC
Created attachment 1354188 [details]
JVM crash log 1

Comment 3 Gregory Lee Bartholomew 2017-11-17 14:30:58 UTC
Created attachment 1354189 [details]
JVM crash log 2

Comment 4 Alexander Kurtakov 2017-11-17 14:45:30 UTC
Leo, is this fixed in master? If yes please point to the patch to be backported.

Comment 5 Lev Ufimtsev 2017-11-20 15:28:16 UTC
(In reply to Gregory Lee Bartholomew from comment #3)

Hello Gregory, 

Seems like a webkit (1/2) crash of sorts. I've implemented a bunch of crash fixes, (but I think I've backported crashers already).

Could you try an integration build and let me know your findings?
http://download.eclipse.org/eclipse/downloads/
(e.g from mid november).

If crashing, does this many any difference?:

cd /eclipse
export SWT_WEBKIT2=1
./eclipse

?

Comment 6 Gregory Lee Bartholomew 2017-11-20 17:45:37 UTC
Sorry, I've overwritten the original image that had the problem.  I tried reinstalling rhythmbox, but I am unable to reproduce the original crash, so I guess the results are inconclusive.

Sorry.

Comment 7 Gregory Lee Bartholomew 2017-11-20 19:26:30 UTC
OK, I just tried deleting ~/.swt and ~/workspace and restarting eclipse.  Java is generating crash logs again, but the IDE is staying open now so I'm not sure that it is exactly the same error.  I just sent a report in through eclipse's auto bug reporting system.

I'll try the integration build now and see if it does any better...

Comment 8 Gregory Lee Bartholomew 2017-11-20 19:40:46 UTC
OK, build I20171115-2000 seems to be running stably and does not generate a JRE SIGSEGV error.

Thanks.

Comment 9 Lev Ufimtsev 2017-11-20 21:37:16 UTC
(In reply to Gregory Lee Bartholomew from comment #8)
> OK, build I20171115-2000 seems to be running stably and does not generate a
> JRE SIGSEGV error.
> 
> Thanks.

I see. I think I've backported relevant crash fixers, but some might only be in 4.7.2.

May I kindly request for you to do a last test run to verify that the bug is fixed in:
4.7.2RC2?

http://download.eclipse.org/eclipse/downloads/

Thank you.

Comment 10 Gregory Lee Bartholomew 2017-11-20 22:33:55 UTC
The bug appears to be fixed in 4.7.2RC2.

Thanks.

Comment 11 Lev Ufimtsev 2017-11-21 14:36:07 UTC
(In reply to Gregory Lee Bartholomew from comment #10)
> The bug appears to be fixed in 4.7.2RC2.
> 
> Thanks.

Thank you for testing and reporting the issue.

Would you consider the bug resolved for the time being or is there something we can help with further?

Comment 12 Gregory Lee Bartholomew 2017-11-21 17:03:02 UTC
I consider it resolved.  Thanks.

Comment 13 Lev Ufimtsev 2017-11-22 14:14:17 UTC
Closing, fix in next release. Thank you for bug report and investigation.


Note You need to log in before you can comment on or make changes to this bug.