Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514221 - Copr fails to clone the repository. Build fails.
Summary: Copr fails to clone the repository. Build fails.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
: 1516437 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 20:50 UTC by Maciej Sitarz
Modified: 2017-12-13 07:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 07:50:56 UTC


Attachments (Terms of Use)

Description Maciej Sitarz 2017-11-16 20:50:21 UTC
Description of problem:
When running builds of the package firefox-nightly I'm getting an error during git clone:

unning: git clone https://github.com/maciex/rpm_specs/ /tmp/tmpaiytf9jm --depth 500 --no-single-branch

cmd: ['git', 'clone', 'https://github.com/maciex/rpm_specs/', '/tmp/tmpaiytf9jm', '--depth', '500', '--no-single-branch']
cwd: .
rc: 128
stdout: 
stderr: fatal: destination path '/tmp/tmpaiytf9jm' already exists and is not an empty directory.

How reproducible:
Always on the firefox-nightly project
Newer on the second project openresolv

Steps to Reproduce:
1. Just run a build on any platform

Actual results:
Repository is not cloned
Build fails.

Expected results:
Repository is cloned
Build succeeds.



Additional info:
https://copr-be.cloud.fedoraproject.org/results/macieks/firefox-nightly/srpm-builds/00663001/builder-live.log


Warning: Permanently added '172.25.85.15' (ECDSA) to the list of known hosts.
Task:
{'build_id': 663001,
 'project_name': 'firefox-nightly',
 'project_owner': 'macieks',
 'source_json': '{"srpm_build_method": "tito", "subdirectory": "firefox-nightly", "committish": "", "clone_url": '
                '"https://github.com/maciex/rpm_specs/", "type": "git", "spec": ""}',
 'source_type': 8}

Running: git clone https://github.com/maciex/rpm_specs/ /tmp/tmpaiytf9jm --depth 500 --no-single-branch

cmd: ['git', 'clone', 'https://github.com/maciex/rpm_specs/', '/tmp/tmpaiytf9jm', '--depth', '500', '--no-single-branch']
cwd: .
rc: 128
stdout: 
stderr: fatal: destination path '/tmp/tmpaiytf9jm' already exists and is not an empty directory.

fatal: destination path '/tmp/tmpaiytf9jm' already exists and is not an empty directory.

Traceback (most recent call last):
  File "/usr/bin/copr-rpmbuild", line 95, in main
    action(args, config)
  File "/usr/bin/copr-rpmbuild", line 125, in build_srpm
    provider.produce_srpm()
  File "/usr/lib/python3.6/site-packages/copr_rpmbuild/providers/scm.py", line 107, in produce_srpm
    self.clone_and_checkout()
  File "/usr/lib/python3.6/site-packages/copr_rpmbuild/providers/scm.py", line 143, in clone_and_checkout
    raise e
  File "/usr/lib/python3.6/site-packages/copr_rpmbuild/providers/scm.py", line 136, in clone_and_checkout
    helpers.run_cmd(clone_cmd)
  File "/usr/lib/python3.6/site-packages/copr_rpmbuild/helpers.py", line 66, in run_cmd
    raise RuntimeError(result.stderr)
RuntimeError: fatal: destination path '/tmp/tmpaiytf9jm' already exists and is not an empty directory.

Comment 1 clime 2017-11-23 08:55:12 UTC
Fixed by https://pagure.io/copr/copr/c/34311cf06521ecbeabc2f52b528a222e1f13ea25.

This will be in production next week. If you want a quick fix, you can use clone URL without the trailing slash: https://github.com/maciex/rpm_specs instead of https://github.com/maciex/rpm_specs/.

Comment 2 clime 2017-11-23 08:58:50 UTC
*** Bug 1516437 has been marked as a duplicate of this bug. ***

Comment 3 clime 2017-12-13 07:50:56 UTC
Hello, sorry for delay here.


Note You need to log in before you can comment on or make changes to this bug.