Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514190 - Installation of intelpython3 2018.1 fails with an rpm error
Summary: Installation of intelpython3 2018.1 fails with an rpm error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 19:01 UTC by Konstantin Belousov
Modified: 2018-02-06 15:33 UTC (History)
11 users (show)

Fixed In Version: rpm-4.14.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-06 15:33:13 UTC


Attachments (Terms of Use)
Problematic rpm (deleted)
2017-11-20 09:50 UTC, Konstantin Belousov
no flags Details
Output of rpm -qp --nosignature --xml (deleted)
2017-11-20 09:51 UTC, Konstantin Belousov
no flags Details
Source RPM patch (deleted)
2018-01-09 16:48 UTC, Nils Smeds
no flags Details | Diff
The source code patch itself (as described above) (deleted)
2018-01-09 16:49 UTC, Nils Smeds
no flags Details | Diff

Description Konstantin Belousov 2017-11-16 19:01:29 UTC
After upgrade from Fedora 26 to Fedora 27, attempt to install intelpython3 2018.1 rpms result in

error: /home/kostik/tmp/l_python3_pu_2018.1.023/rpm/intelpython3-2018.1-023.x86_64.rpm: signature region 62: tag number mismatch il 7 ril 5 dl 658 rdl 16

I am not sure what part is wrong, Intel packaging the stuff with buggy rpm, or updated rpm in Fedora, or format change.

Comment 1 Panu Matilainen 2017-11-17 08:19:14 UTC
Where can I find said rpm(s) for reproduction purposes?

Comment 2 Konstantin Belousov 2017-11-17 14:06:46 UTC
https://software.intel.com/en-us/distribution-for-python
Perhaps you need to register.  Then download python3 for linux, tar archive contains the rpm/ subdirectory.

I am not sure is there the rights to redistribute, most likely not.  So I cannot provide you with the rpms, sorry.

Comment 3 Panu Matilainen 2017-11-17 14:26:51 UTC
Right, registration seems to be required, hmpf.

FWIW, https://github.com/rpm-software-management/rpm/issues/270 is failing on the same (new in 4.14) check and in that case the package is from Intel too, built with rpm5 so maybe that's the case here too. 

If you have access to a system with rpm < 4.14, the output of 'rpm -qp --xml <package>' of an affected package ought to provide some useful clues, for example the rpm version used to build the package.

Comment 4 Konstantin Belousov 2017-11-17 14:55:28 UTC
I have (only) an access to the CentOS with rpm 4.4.2.3.
There I get
$ rpm -qp --xml license-installer-intelpython3-2018.1-023.x86_64.rpm
error: license-installer-intelpython3-2018.1-023.x86_64.rpm: Header V4 RSA/SHA256 signature: BAD, key ID 1911e097

Not sure if this is useful.

That said, perhaps I put the license rpm somewhere, this is not a real software package.  Either contact me by mail or say where to put the rpm.

Comment 5 Panu Matilainen 2017-11-20 09:36:12 UTC
You should be able to get around the invalid signature by adding --nosignature to the query. OTOH a license package is probably a small one so you can just attach here, feel free to mark it private if that seems appropriate.

Anyway, as it appears invalid to other rpm versions too (even if in different manner), this is really further indication that the package is created and/or signed by something else than a rpm.org release.

Comment 6 Konstantin Belousov 2017-11-20 09:50:35 UTC
Created attachment 1355623 [details]
Problematic rpm

Comment 7 Konstantin Belousov 2017-11-20 09:51:53 UTC
Created attachment 1355624 [details]
Output of  rpm -qp --nosignature --xml

Comment 8 Panu Matilainen 2017-11-20 10:34:45 UTC
Thanks, that makes it clear it's not the same exact thing as the similar looking upstream ticket, this is actually produced by rpm 4.4.2.3 but signed by something that creates an unexpected signature header layout. What that something is (home-grown signing thing, buggy rpm version used for signing etc) is another question...

Comment 9 Panu Matilainen 2017-11-28 12:49:46 UTC
Erm, forgot there are actually two separate cases noted in the upstream ticket: one is an rpm5 package, the other one is an rpm.org package signed by something at Intel. In both cases the signature header layout is similarly unexpected even if the details differ somewhat. The rpm5 package actually seems it might well be a bug in rpm5 rather than something intentional.

Haven't quite decided what to do about it though...

Comment 10 Panu Matilainen 2017-11-29 11:07:46 UTC
Fixed upstream by disabling the check for signature header:
https://github.com/rpm-software-management/rpm/commit/34c2ba3c6a80a778cdf2e42a9193b3264e08e1b3

Comment 11 Edward Diener 2017-12-27 20:20:09 UTC
The same problem occurs trying to install Intel Parallel Studio XE Professional Edition for Fortran and C++ Linux 18.0 Update 1 on Fedora 27. It produces the exact same message. It would be nice to get your upstream fix above for Fedora 27. Is that possible somehow ? Will it appear as a normal software update for Fedora 27 or do I have to do anything different to get the fix. The issue, like the one reported here, keeps me from installing the update to Intel C++.

Comment 12 Panu Matilainen 2018-01-02 07:56:28 UTC
Yes there will be an update to fix this. Sooner than later because there are other things needing fixing too.

Comment 13 Andrea Mastellone 2018-01-09 15:04:28 UTC
Confirm this problem on my Fedora 27 machine when trying to install Intel Parallel Studio XE Professional Edition for Fortran and C++ Linux 18.0 Update 1. This problem is of course present even in previous versions of Intel Parallel Studio XE, the culprit being the rpm version 4.14 in F27 (in F26 with rpm 4.13 there was no problem).

Comment 14 Nils Smeds 2018-01-09 16:48:03 UTC
Created attachment 1379191 [details]
Source RPM patch

This patch is not original, but was previously described in this thread.
This is the change to the SPEC file itself

Comment 15 Nils Smeds 2018-01-09 16:49:46 UTC
Created attachment 1379192 [details]
The source code patch itself (as described above)

This patch is not original, but was previously described in this thread.
This is the change to the actual source code

Applying this allows me to install Intel software on Fedora 27

Comment 16 Eric Work 2018-01-22 09:12:47 UTC
The patches from Nils also worked for me to install Intel MKL from their repo.

Comment 17 Fedora Update System 2018-02-01 12:05:41 UTC
rpm-4.14.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf91c45f15

Comment 18 Fedora Update System 2018-02-01 19:32:32 UTC
rpm-4.14.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf91c45f15

Comment 19 Konstantin Belousov 2018-02-02 14:02:53 UTC
Works for me, thank you.

Comment 20 Andrea Mastellone 2018-02-02 14:20:32 UTC
(In reply to Fedora Update System from comment #18)
> rpm-4.14.1-1.fc27 has been pushed to the Fedora 27 testing repository. If
> problems still persist, please make note of it in this bug report.

Working now. Thanks.

Comment 21 Fedora Update System 2018-02-06 15:33:13 UTC
rpm-4.14.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.