Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514108 - SELinux is preventing ModemManager from using the 'dac_override' capabilities.
Summary: SELinux is preventing ModemManager from using the 'dac_override' capabilities.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ed9196a38fb37d04c46692583dc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 16:40 UTC by Alicia Boya García
Modified: 2018-09-03 15:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-20 11:04:38 UTC


Attachments (Terms of Use)

Description Alicia Boya García 2017-11-16 16:40:53 UTC
Description of problem:
SELinux is preventing ModemManager from using the 'dac_override' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that ModemManager should have the dac_override capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ModemManager' --raw | audit2allow -M my-ModemManager
# semodule -X 300 -i my-ModemManager.pp

Additional Information:
Source Context                system_u:system_r:modemmanager_t:s0
Target Context                system_u:system_r:modemmanager_t:s0
Target Objects                Unknown [ capability ]
Source                        ModemManager
Source Path                   ModemManager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-259.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.8-300.fc26.x86_64 #1 SMP Thu
                              Jun 29 20:09:48 UTC 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-07-26 19:23:11 CEST
Last Seen                     2017-07-26 19:23:11 CEST
Local ID                      603c82c4-14c8-41af-8469-dbf6280d0df1

Raw Audit Messages
type=AVC msg=audit(1501089791.512:140): avc:  denied  { dac_override } for  pid=1313 comm="mbim-proxy" capability=1  scontext=system_u:system_r:modemmanager_t:s0 tcontext=system_u:system_r:modemmanager_t:s0 tclass=capability permissive=0


Hash: ModemManager,modemmanager_t,modemmanager_t,capability,dac_override

Version-Release number of selected component:
selinux-policy-3.13.1-259.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.12-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1497668

Comment 1 redhat 2017-12-22 10:57:33 UTC
*** Bug 1528601 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2018-01-02 15:53:26 UTC
Hi, 

Could you follow these steps from your report and attach outputs? 

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

Thanks,
Lukas.

Comment 3 Alicia Boya García 2018-08-20 11:04:38 UTC
It has passed quite a bit of time since I saw this error, so I'm closing it.


Note You need to log in before you can comment on or make changes to this bug.