Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514087 - attached patches are corrupted
Summary: attached patches are corrupted
Keywords:
Status: CLOSED DUPLICATE of bug 738069
Alias: None
Product: Bugzilla
Classification: Community
Component: Attachments/Requests
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 15:58 UTC by Matteo Croce
Modified: 2017-11-16 23:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-16 23:25:36 UTC


Attachments (Terms of Use)
the corrupted patch downloaded from Bugzilla (deleted)
2017-11-16 15:58 UTC, Matteo Croce
no flags Details

Description Matteo Croce 2017-11-16 15:58:52 UTC
Created attachment 1353603 [details]
the corrupted patch downloaded from Bugzilla

Description of problem:

Patches downloaded from Bugzilla are corrupted

Version-Release number of selected component (if applicable):

4.4

How reproducible:

Always

Steps to Reproduce:
1. Open a patch as diff, eg.
   https://bugzilla.redhat.com/attachment.cgi?id=1350621&action=diff
2. Click on "Raw Unified" on the top left

Actual results:

The patch contains a reference to an empty chunk referencing a non existing file named "file_not_specified_in_diff"

Expected results:

The patch file is the same as it was uploaded

Comment 1 Matteo Croce 2017-11-16 16:05:46 UTC
It seems that removing "action=diff" from the URL fixes the bug:

This URL has the bug:
https://bugzilla.redhat.com/attachment.cgi?id=1350621&action=diff&context=patch&collapsed=&headers=1&format=raw

While this one doesn't:
https://bugzilla.redhat.com/attachment.cgi?id=1350621&context=patch&collapsed=&headers=1&format=raw

Comment 2 Jeff Fearn 🐞 2017-11-16 23:25:36 UTC
Fixed in Bugzilla 5.

https://beta-bugzilla.redhat.com/attachment.cgi?id=1277263&action=diff

*** This bug has been marked as a duplicate of bug 738069 ***


Note You need to log in before you can comment on or make changes to this bug.