Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514068 - The engine does not properly identifies the hosted-engine storage domain with the auto import procedure.
Summary: The engine does not properly identifies the hosted-engine storage domain with...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1455169
TreeView+ depends on / blocked
 
Reported: 2017-11-16 15:26 UTC by Nikolai Sednev
Modified: 2018-02-12 11:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:49:09 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
Screenshot from 2016-12-07 15-52-28.png (deleted)
2017-11-16 15:27 UTC, Nikolai Sednev
no flags Details
sosreport from alma04 (deleted)
2017-11-16 15:32 UTC, Nikolai Sednev
no flags Details
engine log (deleted)
2017-11-16 15:33 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84292 master MERGED ansible: engine: force the target VM as the hosted-engine VM 2018-09-03 09:37:53 UTC

Description Nikolai Sednev 2017-11-16 15:26:27 UTC
Description of problem:
The engine does not properly identifies the hosted-engine storage domain with the auto import procedure.

Impossible to add additional HA-host.

For some reason I don't see that crown is yellow over host that is hosting the engine, its grey, like there is no engine is running on host, although I've added data storage domain already over NFS.

I see two hostedengineansible VMs, first one shown as external-hostedengineansible and its down, second shown as hostedengineansible and its up. See photo for more details.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171116111049.gitd675549.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1.Deploy SHE over NFS using hosted-engine --deploy --ansible

Actual results:
The engine does not properly identifies the hosted-engine storage domain with the auto import procedure.

Expected results:
Auto import of hosted-engine storage domain should succeed and additional ha-hosts should be added without errors.

Additional info:
See the attached photo.

Comment 1 Nikolai Sednev 2017-11-16 15:27:03 UTC
Created attachment 1353576 [details]
Screenshot from 2016-12-07 15-52-28.png

Comment 2 Nikolai Sednev 2017-11-16 15:32:23 UTC
Created attachment 1353579 [details]
sosreport from alma04

Comment 3 Nikolai Sednev 2017-11-16 15:33:22 UTC
Created attachment 1353580 [details]
engine log

Comment 4 Martin Sivák 2017-11-16 17:14:09 UTC
This is expected, because the origin field change was not implemented yet...

Comment 6 Nikolai Sednev 2017-11-27 12:48:18 UTC
As discussed with Simone, moving back to assigned.

Comment 7 Martin Sivák 2017-11-27 14:37:26 UTC
This is only a blocker if Node 0 is the default method for ovirt-4.2.0. Which it is not atm.

Comment 8 Martin Sivák 2017-12-06 11:49:50 UTC
The remaining issue is that there is an external VM visible in the VM list right? That is not urgent.

Comment 9 Nikolai Sednev 2017-12-20 07:34:30 UTC
(In reply to Martin Sivák from comment #8)
> The remaining issue is that there is an external VM visible in the VM list
> right? That is not urgent.

The remaining issue is external VM visible and completely failed deployment over FC due to https://bugzilla.redhat.com/show_bug.cgi?id=1455169#c9.

This is still no go for the whole RFC, as FC deployment should work just like NFS, iSCSI and Gluster.

Please consider for appropriate score and severity.

Comment 10 Martin Sivák 2017-12-20 09:10:17 UTC
The whole RFC is in beta status and so this is expected. Also this bug has nothing to do with external VM being visible or FC your issue. I wish you would create a separate bug for the external VM and use the proper bug for the FC issue so we can properly close this one.

Comment 11 Nikolai Sednev 2017-12-20 09:56:11 UTC
(In reply to Martin Sivák from comment #10)
> The whole RFC is in beta status and so this is expected. Also this bug has
> nothing to do with external VM being visible or FC your issue. I wish you
> would create a separate bug for the external VM and use the proper bug for
> the FC issue so we can properly close this one.

https://bugzilla.redhat.com/show_bug.cgi?id=1527866 had been opened to separate that issue from this bug.

Comment 12 Nikolai Sednev 2017-12-20 10:18:26 UTC
FC issue separated by opening this bug here https://bugzilla.redhat.com/show_bug.cgi?id=1527876

Comment 13 RHV Bugzilla Automation and Verification Bot 2018-01-18 17:39:19 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: infra@ovirt.org

Comment 14 Nikolai Sednev 2018-01-22 15:51:19 UTC
Works for me just fine on these components:
ovirt-hosted-engine-setup-2.2.7-0.0.master.20180119084226.git3799ea2.el7.centos.noarch
ovirt-hosted-engine-ha-2.2.5-0.0.master.20180117160214.20180117160210.gitd5b58a8.el7.centos.noarch
ovirt-engine-appliance-4.2-20180121.1.el7.centos.noarch

Moving to verified.

Comment 15 Sandro Bonazzola 2018-02-12 11:49:09 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.