Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514047 - [abrt] bleachbit: run_operations(): Worker.py:326:run_operations:KeyError: 'chrome'
Summary: [abrt] bleachbit: run_operations(): Worker.py:326:run_operations:KeyError: 'c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bleachbit
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bcd6a498d1819dfa349c7660d3f...
: 1475360 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 14:53 UTC by RobbieTheK
Modified: 2018-03-16 16:17 UTC (History)
1 user (show)

Fixed In Version: bleachbit-2.0-1.fc27 bleachbit-2.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-13 23:17:10 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details
File: cgroup (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details
File: cpuinfo (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details
File: environ (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details
File: mountinfo (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details
File: namespaces (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details
File: open_fds (deleted)
2017-11-16 14:53 UTC, RobbieTheK
no flags Details

Description RobbieTheK 2017-11-16 14:53:44 UTC
Description of problem:
running the program caused it

Version-Release number of selected component:
bleachbit-1.12-2.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python2 /usr/bin/bleachbit -c chrome.cache
crash_function: run_operations
exception_type: KeyError
executable:     /usr/bin/bleachbit
kernel:         4.12.9-300.fc26.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
Worker.py:326:run_operations:KeyError: 'chrome'

Traceback (most recent call last):
  File "/usr/bin/bleachbit", line 51, in <module>
    bleachbit.CLI.process_cmd_line()
  File "/usr/share/bleachbit/CLI.py", line 204, in process_cmd_line
    preview_or_clean(operations, True)
  File "/usr/share/bleachbit/CLI.py", line 88, in preview_or_clean
    while worker.next():
  File "/usr/share/bleachbit/Worker.py", line 245, in run
    for dummy in self.run_operations(self.operations):
  File "/usr/share/bleachbit/Worker.py", line 326, in run_operations
    name = backends[operation].get_name()
KeyError: 'chrome'

Local variables in innermost frame:
count: 0
operation: 'chrome'
my_operations: {'chrome': ['cache']}
self: <bleachbit.Worker.Worker instance at 0x7fd2d547d488>

Comment 1 RobbieTheK 2017-11-16 14:53:47 UTC
Created attachment 1353545 [details]
File: backtrace

Comment 2 RobbieTheK 2017-11-16 14:53:48 UTC
Created attachment 1353546 [details]
File: cgroup

Comment 3 RobbieTheK 2017-11-16 14:53:49 UTC
Created attachment 1353547 [details]
File: cpuinfo

Comment 4 RobbieTheK 2017-11-16 14:53:50 UTC
Created attachment 1353548 [details]
File: environ

Comment 5 RobbieTheK 2017-11-16 14:53:51 UTC
Created attachment 1353549 [details]
File: mountinfo

Comment 6 RobbieTheK 2017-11-16 14:53:53 UTC
Created attachment 1353550 [details]
File: namespaces

Comment 7 RobbieTheK 2017-11-16 14:53:54 UTC
Created attachment 1353551 [details]
File: open_fds

Comment 8 Mukundan Ragavan 2017-11-17 20:32:57 UTC
*** Bug 1475360 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-03-07 22:49:23 UTC
bleachbit-2.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a6e39e3ac

Comment 10 Fedora Update System 2018-03-07 22:49:47 UTC
bleachbit-2.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2a30a3fb54

Comment 11 Fedora Update System 2018-03-08 16:23:03 UTC
bleachbit-2.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a6e39e3ac

Comment 12 Fedora Update System 2018-03-08 16:28:12 UTC
bleachbit-2.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2a30a3fb54

Comment 13 Fedora Update System 2018-03-13 23:17:10 UTC
bleachbit-2.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-03-16 16:17:44 UTC
bleachbit-2.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.