Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1514023 - Lots of WebSocket errors when logging out and logging in to the GUI
Summary: Lots of WebSocket errors when logging out and logging in to the GUI
Keywords:
Status: CLOSED DUPLICATE of bug 1507425
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Honza Pokorny
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 13:53 UTC by Udi
Modified: 2018-03-09 19:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-07 06:39:42 UTC


Attachments (Terms of Use)

Description Udi 2017-11-16 13:53:53 UTC
Description of problem:
When you log out of the GUI, and you have the console window (F12) open, you start seeing these errors:

tripleo_ui.js:43 WebSocket is already in CLOSING or CLOSED state

When you log back in you see the above message many more times. The GUI seems to be working, no noticeable implications result from this error, but with the console window open it is visible and looks serious.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.3-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Open the console window (F12).
2. Log out.
3. Log back in.


Actual results:
tripleo_ui.js:43 WebSocket is already in CLOSING or CLOSED state.
t.default.sendMessage @ tripleo_ui.js:43(anonymous function) @ tripleo_ui.js:42(anonymous function) @ tripleo_ui.js:122l.value @ tripleo_ui.js:88(anonymous function) @ tripleo_ui.js:88l.value @ tripleo_ui.js:88(anonymous function) @ tripleo_ui.js:43a.value @ tripleo_ui.js:43t.(anonymous function) @ tripleo_ui.js:43(anonymous function) @ tripleo_ui.js:122e @ tripleo_ui.js:122(anonymous function) @ tripleo_ui.js:122(anonymous function) @ tripleo_ui.js:122c.dispatch @ tripleo_ui.js:122(anonymous function) @ tripleo_ui.js:38(anonymous function) @ tripleo_ui.js:122fetchPlans @ tripleo_ui.js:77s.value @ tripleo_ui.js:77e.notifyAll @ tripleo_ui.js:67p.close @ tripleo_ui.js:116a.closeAll @ tripleo_ui.js:42a.perform @ tripleo_ui.js:42a.perform @ tripleo_ui.js:42d.perform @ tripleo_ui.js:37k @ tripleo_ui.js:37E.close @ tripleo_ui.js:37a.closeAll @ tripleo_ui.js:42a.perform @ tripleo_ui.js:42d.perform @ tripleo_ui.js:37k @ tripleo_ui.js:37a.closeAll @ tripleo_ui.js:42a.perform @ tripleo_ui.js:42f.batchedUpdates @ tripleo_ui.js:116l @ tripleo_ui.js:37r @ tripleo_ui.js:47u.enqueueSetState @ tripleo_ui.js:47r.setState @ tripleo_ui.js:61s.handleChange @ tripleo_ui.js:119c @ tripleo_ui.js:69(anonymous function) @ tripleo_ui.js:122(anonymous function) @ tripleo_ui.js:122c.dispatch @ tripleo_ui.js:122(anonymous function) @ tripleo_ui.js:40i @ tripleo_ui.js:89(anonymous function) @ tripleo_ui.js:89u @ tripleo_ui.js:43
tripleo_ui.js:88 action @ 15:44:20.674 FETCH_WORKFLOW_EXECUTIONS_PENDING

Comment 2 Jiri Tomasek 2017-11-20 12:40:53 UTC
Note that this issue happens only when 'zaqar' logger is enabled.

Comment 3 Jiri Tomasek 2017-11-20 12:48:28 UTC
Apparently Zaqar logger tries to send messages even when Zaqar connection is closed instead of queuing messages. Message queuing happens only when Zaqar WebSocket connection is not initially established and once connection is authenticated, it flushes messages and starts sending them directly from that point.

We need to add a mechanism which gets back to queuing messages when Zaqar WebSocket connection is  closed.

Comment 7 Honza Pokorny 2018-02-06 18:11:02 UTC
I propose that close this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1507425

Comment 8 Udi 2018-02-07 06:39:42 UTC

*** This bug has been marked as a duplicate of bug 1507425 ***


Note You need to log in before you can comment on or make changes to this bug.