Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513996 - VM is restarted rather than resumed on dehibernation
Summary: VM is restarted rather than resumed on dehibernation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Arik
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 13:01 UTC by Milan Zamazal
Modified: 2017-12-20 10:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:59:54 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
rule-engine: blocker+
ahadas: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84266 master MERGED core: send hibernation-vol-handle for suspended vms 2017-11-19 12:06:40 UTC

Description Milan Zamazal 2017-11-16 13:01:42 UTC
Description of problem:

When a VM is suspended and then re-run, it's newly started rather than resumed to its last state.

Version-Release number of selected component (if applicable):

oVirt master

How reproducible:

Always.

Steps to Reproduce:
1. Start a VM.
2. Perform some change inside the running VM to distinguish it from a freshly started VM.
3. Use "Suspend" web UI button to suspend it.
4. Once the VM is suspended, run it again with "Run" button again.
5. Look inside the VM and check whether the VM has been resumed to the previous state or newly started.

Actual results:

The VM is newly started.

Expected results:

The VM is resumed from its suspended state.

Additional info:

The problem is that hiberVolHandle parameter is not sent from Engine on VM.create call.

Comment 1 Yaniv Kaul 2017-11-17 06:38:24 UTC
I assume we need to test the flow better in o-s-t?

Comment 2 Milan Zamazal 2017-11-20 08:08:09 UTC
(In reply to Yaniv Kaul from comment #1)
> I assume we need to test the flow better in o-s-t?

Yes, we should check not only for UP status there but also that the inner state of the VM is retained.

Comment 3 Israel Pinto 2017-12-13 13:43:45 UTC
Verify with:
Engine: Software Version:4.2.0.2-0.1.el7
Host:
OS Version:RHEL - 7.4 - 18.el7
Kernel Version:3.10.0 - 693.el7.x86_64
KVM Version:2.9.0 - 16.el7_4.12
LIBVIRT Version:libvirt-3.2.0-14.el7_4.5
VDSM Version:vdsm-4.20.9.1-1.el7ev

Steps:
1. Create vm with OS
2, Start VM and create file with content on VM
3. Suspend VM
4. Resume VM
5. Check File exists on VM

Pass

Comment 4 Sandro Bonazzola 2017-12-20 10:59:54 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.