Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513890 - --std=c++14 no longer required
Summary: --std=c++14 no longer required
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: root
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 08:53 UTC by gilles.arnaud
Modified: 2017-11-17 17:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-17 17:15:08 UTC


Attachments (Terms of Use)

Description gilles.arnaud 2017-11-16 08:53:48 UTC
Description of problem:
root seems to have been compiled with the --std=c++14 option
this option was needed for old root version 6.6 combined gcc6, but now they are
not necessary and the implicit c++11 option works.

when we develop extra library for root, it is irritating as it demand to force  this option and 
may cause conflict (linking with cppunit produces many undefined symbol)

Version-Release number of selected component (if applicable):
f26 f27 

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Mattias Ellert 2017-11-17 17:15:08 UTC
C++14 is the default C++ standard version in GCC 6.1 and later. This means that C++14 has been the default C++ standard version in Fedora since release 24. In Fedora today many libraries provided by the distribution do use C++14 features in their headers, and downgrading the compiler using --std=x++11 would make compiling using these libraries fail. The root package in Fedora 24+ is compiled using C++14 in order to avoid being incompatible with other libraries provided by the distribution.


Note You need to log in before you can comment on or make changes to this bug.