Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513867 - [ovs-conntrack] change ovs-dpdk to ovs-kernel environment , packets captured are out of order
Summary: [ovs-conntrack] change ovs-dpdk to ovs-kernel environment , packets captured ...
Keywords:
Status: CLOSED DUPLICATE of bug 1513881
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Open vSwitch development team
QA Contact: ovs-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-16 07:28 UTC by Jiying Qiu
Modified: 2017-11-16 08:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-16 08:22:18 UTC


Attachments (Terms of Use)
the packets to be send (deleted)
2017-11-16 07:28 UTC, Jiying Qiu
no flags Details
the packets captured out of order (deleted)
2017-11-16 07:30 UTC, Jiying Qiu
no flags Details

Description Jiying Qiu 2017-11-16 07:28:15 UTC
Description of problem:
server(ovs)------------client(trex)
change the server from ovs-dpdk environment to ovs-kernel ,then the client use trex send packets.packets captured in the server side are out of order.

Version-Release number of selected component (if applicable):
[root@dell-per730-25 ct_kernel]# uname -a 
Linux dell-per730-25.rhts.eng.pek2.redhat.com 3.10.0-693.el7.x86_64 #1 SMP Thu Jul 6 19:56:57 EDT 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-per730-25 ct_kernel]# rpm -qa openvswitch
openvswitch-2.7.3-2.git20171010.el7fdp.x86_64

SERVERS=dell-per730-25.rhts.eng.pek2.redhat.com
CLIENTS=dell-per730-26.rhts.eng.pek2.redhat.com

How reproducible:
run kernel/networking/openvswitch/conntrack3/ct_userspace  and then take the nic out of the dpdk in server . After that,run ovs-kernel and send packets, the packets are out of order.

Steps to Reproduce:
1.the server has a vm ,there is a bridge within the vm two nics.and the nics of the server are in the dpdk usersapce. The open flow are as following:
ovs-ofctl del-flows $ovsbr
ovs-ofctl add-flow $ovsbr  "table=0,priority=1,action=drop"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=10,arp,action=11"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=11,arp,action=10"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=20,arp,action=21"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=21,arp,action=20"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=10,sctp,action=11"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=11,sctp,action=10"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=20,sctp,action=21"
ovs-ofctl add-flow $ovsbr  "table=0,priority=10,in_port=21,sctp,action=20"
ovs-ofctl add-flow $ovsbr  "table=0,priority=100,tcp,ct_state=-trk,action=ct(table=1)"

ovs-ofctl add-flow $ovsbr  "table=1,in_port=10,tcp,ct_state=+trk+new,action=ct(commit),11"
ovs-ofctl add-flow $ovsbr  "table=1,in_port=21,tcp,ct_state=+trk+new,action=ct(commit),20"
ovs-ofctl add-flow $ovsbr  "table=1,in_port=10,ct_state=+trk+est,tcp,action=11"
ovs-ofctl add-flow $ovsbr  "table=1,in_port=11,tcp,action=10"
ovs-ofctl add-flow $ovsbr  "table=1,in_port=20,ct_state=+trk+est,tcp,action=21"
ovs-ofctl add-flow $ovsbr  "table=1,in_port=21,tcp,action=20"
ovs-ofctl add-flow $ovsbr  "table=1,ct_state=+trk+inv,tcp,action=drop"
ovs-ofctl add-flow $ovsbr  "table=1,action=drop"
ovs-ofctl dump-flows $ovsbr
2.the client use trex send http_600B.pcap
./t-rex-64 -f cps.yaml -c 10 -m 1 -d 5 --nc --checksum-offload 
3.take the nics out of dpdk ,and down/up.put them in ovs-kernel environment
4.the client use trex send http_600B.pcap,and the server capture packets in nic p7p1
./t-rex-64 -f cps.yaml -c 10 -m 1 -d 300 --nc --checksum-offload

Actual results:
the packets captured are out of order

Expected results:
the packets captured are normal

Additional info:

[root@dell-per730-25 ct_kernel]# ovs-ofctl dump-ports-desc ovsbr0
OFPST_PORT_DESC reply (xid=0x2):
 10(p7p1): addr:a0:36:9f:ab:36:c4
     config:     0
     state:      0
     current:    10GB-FD
     advertised: 10GB-FD FIBER AUTO_PAUSE
     supported:  10GB-FD FIBER AUTO_PAUSE
     speed: 10000 Mbps now, 10000 Mbps max
 11(vnet1): addr:fe:de:ad:01:01:01
     config:     0
     state:      0
     current:    10MB-FD COPPER
     speed: 10 Mbps now, 0 Mbps max
 20(p7p2): addr:a0:36:9f:ab:36:c6
     config:     0
     state:      0
     current:    10GB-FD
     advertised: 10GB-FD FIBER AUTO_PAUSE
     supported:  10GB-FD FIBER AUTO_PAUSE
     speed: 10000 Mbps now, 10000 Mbps max
 21(vnet2): addr:fe:de:ad:01:01:02
     config:     0
     state:      0
     current:    10MB-FD COPPER
     speed: 10 Mbps now, 0 Mbps max
 LOCAL(ovsbr0): addr:a0:36:9f:ab:36:c4
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max

[root@dell-per730-25 ct_kernel]# ethtool -i p7p1 
driver: ixgbe
version: 4.4.0-k-rh7.4
firmware-version: 0x800007f5
expansion-rom-version: 
bus-info: 0000:05:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no

Comment 2 Jiying Qiu 2017-11-16 07:30:22 UTC
Created attachment 1353269 [details]
the packets captured out of order

Comment 3 Jiying Qiu 2017-11-16 08:22:18 UTC

*** This bug has been marked as a duplicate of bug 1513881 ***


Note You need to log in before you can comment on or make changes to this bug.