Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513756 - Output from Ansible Job Template should be visible in CloudForms
Summary: Output from Ansible Job Template should be visible in CloudForms
Keywords:
Status: CLOSED DUPLICATE of bug 1590840
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: lgalis
QA Contact: Pavol Kotvan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 22:10 UTC by Jerome Marc
Modified: 2018-08-07 14:00 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-06 16:13:40 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jerome Marc 2017-11-15 22:10:36 UTC
Description of problem:
Standard output for Ansible Job Template launched from Ansible Tower are not visible in CloudForms. They are however displayed for Embedded Ansible. This should be consistent

Version-Release number of selected component (if applicable):
5.9.0.8.20171109215303_ed87902

How reproducible:
Always

Steps to Reproduce:
1. Launch a Job Template from CloudForms
2. Try to find the output
3.

Actual results:
Standard output is not displayed in CloudForms for Job Templates.

Expected results:
Standard output should be displayed in CloudForms for Job Templates.

Additional info:

Comment 3 Greg McCullough 2018-04-12 15:06:30 UTC
Passing to Brad for feedback on this feature request:

From the backend the service class exposes a job method and that job has an accessor to the Tower stdout.  Note: Since we do not control the Tower instance we cannot guarantee that the job or job output will always be available.

Comment 4 bascar 2018-05-01 18:17:32 UTC
Then show when there is data is available and show data is not/is no longer available in the external Tower instance.

Comment 5 Tomas Coufal 2018-08-06 16:13:40 UTC
Hi! I think this was already solved in tickets

https://bugzilla.redhat.com/show_bug.cgi?id=1590840
https://bugzilla.redhat.com/show_bug.cgi?id=1590844

Please reopen if the implemented solution doesn't suit your needs.

*** This bug has been marked as a duplicate of bug 1590840 ***


Note You need to log in before you can comment on or make changes to this bug.