Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513714 - [SOLVED] gnome-shell spent a lot of CPU when screen is locked
Summary: [SOLVED] gnome-shell spent a lot of CPU when screen is locked
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 20:22 UTC by Álvaro Castillo
Modified: 2017-11-20 15:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 15:50:07 UTC


Attachments (Terms of Use)
top capture (deleted)
2017-11-15 20:22 UTC, Álvaro Castillo
no flags Details
CPU information (deleted)
2017-11-15 20:26 UTC, Álvaro Castillo
no flags Details
PCI information (deleted)
2017-11-15 20:26 UTC, Álvaro Castillo
no flags Details
USB information (deleted)
2017-11-15 20:26 UTC, Álvaro Castillo
no flags Details
Xorg.0.log (deleted)
2017-11-15 20:27 UTC, Álvaro Castillo
no flags Details
Xorg.1.log (deleted)
2017-11-15 20:27 UTC, Álvaro Castillo
no flags Details
Upgraded system, ID 46 (deleted)
2017-11-20 15:47 UTC, Álvaro Castillo
no flags Details
Upgraded system ID 51 (deleted)
2017-11-20 15:48 UTC, Álvaro Castillo
no flags Details

Description Álvaro Castillo 2017-11-15 20:22:31 UTC
Created attachment 1352950 [details]
top capture

Description of problem:
gnome-shell process takes a lot of CPU spent. Fan increases a lot speed.

Version-Release number of selected component (if applicable):
Fedora 27 with full updated system.

How reproducible:
Go to the right part of menu user.
Clic at power button.
Clic lock icon
Wait 3-4 seconds
TaDa!

Actual results:


Expected results:
No increase fan speed and CPU usage.

Additional info:
I have added a top captured in the moment I locked my session with GNOME.

Comment 1 Álvaro Castillo 2017-11-15 20:26:16 UTC
Created attachment 1352952 [details]
CPU information

Comment 2 Álvaro Castillo 2017-11-15 20:26:37 UTC
Created attachment 1352953 [details]
PCI information

Comment 3 Álvaro Castillo 2017-11-15 20:26:58 UTC
Created attachment 1352955 [details]
USB information

Comment 4 Álvaro Castillo 2017-11-15 20:27:23 UTC
Created attachment 1352956 [details]
Xorg.0.log

Comment 5 Álvaro Castillo 2017-11-15 20:27:48 UTC
Created attachment 1352957 [details]
Xorg.1.log

Comment 6 Álvaro Castillo 2017-11-15 20:29:31 UTC
kernel version:

Linux keys0 4.13.12-300.fc27.x86_64 #1 SMP Wed Nov 8 16:38:01 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Comment 7 Álvaro Castillo 2017-11-20 15:47:42 UTC
Created attachment 1355931 [details]
Upgraded system, ID 46

Comment 8 Álvaro Castillo 2017-11-20 15:48:05 UTC
Created attachment 1355932 [details]
Upgraded system ID 51

Comment 9 Álvaro Castillo 2017-11-20 15:50:07 UTC
This issue was solved.

I perform twice upgrade software and I don't get more problem with it.

Added .txt about whats changed has been produced for differents updates of the system.


I have to executed too this commands because I get SELinux AVC denials.

ausearch -c 'vboxdrv.sh' --raw | audit2allow -M my-vboxdrvsh
semodule -X 300 -i my-vboxdrvsh.pp

ausearch -c 'bwrap' --raw | audit2allow -M my-bwrap
semodule -X 300 -i my-bwrap.pp


Note You need to log in before you can comment on or make changes to this bug.