Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513710 - evince fails to open djvu file (regression)
Summary: evince fails to open djvu file (regression)
Keywords:
Status: CLOSED DUPLICATE of bug 1513188
Alias: None
Product: Fedora
Classification: Fedora
Component: djvulibre
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 20:01 UTC by Fabrice Bellet
Modified: 2017-11-20 15:26 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-20 15:26:10 UTC


Attachments (Terms of Use)

Description Fabrice Bellet 2017-11-15 20:01:58 UTC
After an upgrade from F26 to F27, evince fails to open djvu files, even with installed evince-djvu subpackage.

Comment 1 Fabrice Bellet 2017-11-15 21:47:24 UTC
Workaround : 
# rpm -e djview4 djview4-plugin djvulibre djvulibre-libs
# dnf install djview4 djview4-plugin djvulibre djvulibre-libs

(doing that for each rpm separately is not sufficient)

Comment 2 Fabrice Bellet 2017-11-15 22:12:15 UTC
ah got it. the problem is with djvulibre postinstall scriptlets, that don't rerun update-mime-database after package removal (moreover the preuninstall scriptlet fails with a non existing script /usr/share/djvu/osi/desktop/register-djvu-mime) . reassigning to djvulibre.

Comment 3 Toni Andjelkovic 2017-11-18 23:53:57 UTC
This is a duplicate of #1513188 "multipage djvu files are misidentified".

Comment 4 Caolan McNamara 2017-11-20 15:26:10 UTC

*** This bug has been marked as a duplicate of bug 1513188 ***


Note You need to log in before you can comment on or make changes to this bug.