Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513693 - [DOCS] Mixed Environment Upgrades require setting both openshift_pkg_version and openshift_image_tag
Summary: [DOCS] Mixed Environment Upgrades require setting both openshift_pkg_version ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ashley Hardin
QA Contact: Weihua Meng
Vikram Goyal
URL:
Whiteboard: 3.10-release-plan
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 19:12 UTC by Josh Foots
Modified: 2018-06-15 22:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 19:23:17 UTC


Attachments (Terms of Use)

Description Josh Foots 2017-11-15 19:12:00 UTC
Document URL: 

https://docs.openshift.com/container-platform/3.6/install_config/upgrading/automated_upgrades.html

Section Number and Name: 

Describe the issue: 

$summary needs to be added to this document.

Additional information: 

In a mixed env (rh7 and atomic), if you only specify openshift_pkg_version then that number is used for the packages for rh7 AND the image for atomic.

  # At this point we know openshift_version is set appropriately. Now we set
  # openshift_image_tag and openshift_pkg_version, so all roles can always assume
  # each of this variables *will* be set correctly and can use them per their
  # intended purpose.

  - block:
    - debug:
        msg: "openshift_image_tag was not defined. Falling back to v{{ openshift_version }}"

https://github.com/openshift/openshift-ansible/blob/91c1c6fc7323ca885956102248b2e5b18e5332c3/roles/openshift_version/tasks/main.yml#L148-L155

  block:
  - name: Set openshift_version for rpm installation
    include: set_version_rpm.yml
    when: not is_containerized | bool

  - name: Set openshift_version for containerized installation
    include: set_version_containerized.yml
    when: is_containerized | bool
https://github.com/openshift/openshift-ansible/blob/91c1c6fc7323ca885956102248b2e5b18e5332c3/roles/openshift_version/tasks/main.yml#L104-L111


https://github.com/openshift/openshift-ansible/blob/57185bdd2415d4bbdeb6d18dfdaea65d0c440ae1/roles/openshift_version/tasks/set_version_rpm.yml
https://github.com/openshift/openshift-ansible/blob/57185bdd2415d4bbdeb6d18dfdaea65d0c440ae1/roles/openshift_version/tasks/set_version_containerized.yml

Comment 2 Weihua Meng 2018-04-18 10:10:11 UTC
LGTM.

I see 3.7, 3.9, 3.10 in PR, I guess 3.6 also needed, please check.

Comment 3 Ashley Hardin 2018-04-18 16:09:16 UTC
Thank you! Content is now added to 3.6 docs via https://github.com/openshift/openshift-docs/pull/8786


Note You need to log in before you can comment on or make changes to this bug.