Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513599 - foreman-maintain lower cases the uppercase characters while saving hammer credentials
Summary: foreman-maintain lower cases the uppercase characters while saving hammer cre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Maintain
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Katello QA List
URL:
Whiteboard:
: 1518203 1523702 (view as bug list)
Depends On:
Blocks: 1122832 1533259
TreeView+ depends on / blocked
 
Reported: 2017-11-15 16:33 UTC by sthirugn@redhat.com
Modified: 2019-04-12 15:04 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-04 17:54:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0033 normal SHIPPED_LIVE Satellite Maintenance bug fix update 2018-01-04 22:53:47 UTC
Foreman Issue Tracker 21721 None None None 2017-12-05 09:59:28 UTC

Description sthirugn@redhat.com 2017-11-15 16:33:50 UTC
Description of problem:
foreman-maintain lower cases the uppercase characters while saving hammer credentials

Version-Release number of selected component (if applicable):
rubygem-foreman_maintain-0.0.11-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Say Satellite hammer password is CHANGEME!@#$%
2. Install rubygem-foreman_maintain 
3. Run any foreman-maintain command: Example:
# foreman-maintain upgrade check --target-version 6.3.z

Running preparation steps required to run the next scenarios
================================================================================
Setup hammer: 
Hammer username [admin]: 
Hammer password: 
Invalid credentials

Actual results:
The foreman-maintain fails with invalid credentials even though you enter the right password

/etc/foreman-maintain/foreman-maintain-hammer.yml saves the password as `changeme!@#$%`

All the upper case characters are lowercased.  As far as I checked, the special characters look fine.

Expected results:
credentials should be saved properly

Additional info:
Changing the credentials in /etc/foreman-maintain/foreman-maintain-hammer.yml works fine.

Comment 1 Anurag Patel 2017-11-15 20:26:53 UTC
Looks to me like the common ask() method is downcasing user's responses, and would affect uppercase usernames too. Will address this.

Comment 3 Ivan Necas 2017-11-28 12:04:34 UTC
*** Bug 1518203 has been marked as a duplicate of this bug. ***

Comment 4 pm-sat@redhat.com 2017-12-06 13:21:59 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/21721 has been resolved.

Comment 7 Mike McCune 2017-12-15 21:06:19 UTC
This works perfectly with the update to foreman-maintain 0.1

Comment 10 errata-xmlrpc 2018-01-04 17:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0033

Comment 11 Anurag Patel 2018-01-10 12:47:06 UTC
*** Bug 1523702 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.