Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513581 - document configuration and behavior of alerting via SNMPv3 trap messages in tendrl-notifier
Summary: document configuration and behavior of alerting via SNMPv3 trap messages in t...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-RHGS_Web_Administration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.3.1
Assignee: Rakesh
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 16:03 UTC by Martin Bukatovic
Modified: 2018-08-28 09:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-30 18:00:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1511321 None None None Never

Internal Links: 1511321

Description Martin Bukatovic 2017-11-15 16:03:18 UTC
Document URL
============

There is no url yet, this is related to documentation for RHGS WA.

Describe the issue
==================

Since we have implemented sending tendrl notifications via SNMPv3
trap messages, we need to document how to configure it and what is
expected behavior here.

Additional information
======================

This BZ is created based on irc discussion with Rakesh Ghatvisave.

Related Upstream Resources
==========================

* Installation Guide[1] mentions configuration of SNMP alerting in section
  Tendrl Server Installation, search for "Configure email/snmp source" step.
* Basic description of alerting is given in List of Alerts and Notifications[2]

[1] https://github.com/Tendrl/documentation/wiki/Tendrl-release-v1.5.4-(install-guide)#tendrl-server-installation
[2] https://github.com/Tendrl/documentation/wiki/List-of-Alerts-and-Notifications-in-Tendrl

Comment 2 Martin Bukatovic 2017-11-15 16:05:58 UTC
bobbGT, feel free to reassign this BZ to a correct component.

Comment 3 Martin Bukatovic 2017-11-15 16:09:17 UTC
For additional information, you can ask:

* shtripat or rohan from dev team
* mbukatov who is testing this feature

Comment 7 Rakesh 2017-11-23 23:48:14 UTC
Documenting SNMPv3 configuration in the Monitoring Guide:

https://access.qa.redhat.com/documentation/en-us/red_hat_gluster_storage/3.3/html-single/monitoring_guide/#alerts_and_snmp_configuration

Martin, in Table 9.3. Gluster Native Events of the Guide, do we have a list of system resources or it's not applicable?

Comment 10 Martin Bukatovic 2017-11-25 18:10:03 UTC
Bob, the current status is that tendrl doens't process gluster native events
in general, see BZ 1517468.


Note You need to log in before you can comment on or make changes to this bug.