Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513559 - Some filter element items are named ManageIQ providers
Summary: Some filter element items are named ManageIQ providers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Gregg Tanzillo
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:filter
Depends On:
Blocks: 1527092
TreeView+ depends on / blocked
 
Reported: 2017-11-15 15:41 UTC by Matouš Mojžíš
Modified: 2018-06-21 21:17 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1527092 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:17:53 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)
manageiq_filters (deleted)
2017-11-15 15:41 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2017-11-15 15:41:20 UTC
Created attachment 1352695 [details]
manageiq_filters

Description of problem:


Version-Release number of selected component (if applicable):
5.8.2.3
5.9.0.8

How reproducible:
Always

Steps to Reproduce:
1. Go for example to Compute -> Cloud -> Key Pairs or Anything in Networks section.
2. Try to add Field element and there are ManageIQ Providers items.
3.

Actual results:
ManageIQ Providers filter element type is displayed.

Expected results:
It should be renamed to CFME Providers.

Additional info:

Comment 2 Joe Rafaniello 2017-12-07 17:13:27 UTC
These are the names of the classes.  Do we normally translate other pulldowns to change classes to remove ManageIQ?  I'm leaning towards "this is the way it is since we're showing the class name".  If we wanted a more user friendly class name, that's something else and I believe we have that problem in other areas so we'd need a general solution to that problem.  What do you think?

Comment 3 Joe Rafaniello 2017-12-12 19:26:21 UTC
Reassigning to UI team for review.  I don't believe we translate class names out of the UI but would like them to confirm it.

Comment 5 CFME Bot 2017-12-15 21:41:49 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/08c93ebc20252ecbd2d93d71016f32dc9d313a35

commit 08c93ebc20252ecbd2d93d71016f32dc9d313a35
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Thu Dec 14 09:09:42 2017 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Thu Dec 14 09:09:42 2017 -0500

    Add proper translation for manageiq_providers_cloud_manager_vms
    so that it appears as "Instances" in report and expression editor list.
    
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1513559

 locale/en.yml | 1 +
 1 file changed, 1 insertion(+)

Comment 7 CFME Bot 2018-01-04 22:00:53 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/e364f3153188c853e79047116c7f2d6cd13162a5

commit e364f3153188c853e79047116c7f2d6cd13162a5
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Thu Jan 4 15:52:10 2018 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Thu Jan 4 16:11:54 2018 -0500

    Add more translations for cloud resources and templates
    
    so they appear properly in report and expression editor lists.
    
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1513559
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1527092

 locale/en.yml | 3 +++
 1 file changed, 3 insertions(+)


Note You need to log in before you can comment on or make changes to this bug.