Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513555 - Rebase libsolv to latest version
Summary: Rebase libsolv to latest version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libsolv
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Rohel
QA Contact: Desktop QE
URL:
Whiteboard:
: 1561340 (view as bug list)
Depends On:
Blocks: 1549618
TreeView+ depends on / blocked
 
Reported: 2017-11-15 15:38 UTC by Igor Gnatenko
Modified: 2018-10-30 11:27 UTC (History)
11 users (show)

Fixed In Version: libsolv-0.6.34-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:26:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3234 None None None 2018-10-30 11:27:07 UTC

Description Igor Gnatenko 2017-11-15 15:38:12 UTC
There are a lot of bugfixes and improvements. Also kinda needed for yum4 (one of next versions). Even we don't ship yum4 in RHEL7, we still try to make it simple to ship it in CentOS/EPEL.

Comment 1 Terry Bowling 2018-03-03 00:39:08 UTC
Igor,

Could you please summarize, or provide a link to details, of the changes or impact of the rebase.  We simply need to understand any negative impact to anything that might already be using libsolv.

Comment 2 Igor Gnatenko 2018-03-03 07:14:06 UTC
(In reply to Terry Bowling from comment #1)
> Igor,
> 
> Could you please summarize, or provide a link to details, of the changes or
> impact of the rebase.  We simply need to understand any negative impact to
> anything that might already be using libsolv.

https://github.com/openSUSE/libsolv/blob/master/NEWS

There were no breakages from current version, so nothing should break. Only new features and bugfixes.

Comment 3 Igor Gnatenko 2018-03-08 08:49:54 UTC
Turns out, this is also needed for internal deployment of MBS (for RHEL8, but deployed on RHEL7).

Increasing priority.

Comment 4 Igor Gnatenko 2018-03-08 09:06:08 UTC
⋊> ~/P/r/r/libsolv on rhel-7.5 ⨯ abipkgdiff libsolv-0.6.26-2.el7.x86_64.rpm libsolv-0.6.33-1.el7.x86_64.rpm --devel1 libsolv-devel-0.6.26-2.el7.x86_64.rpm --devel2 libsolv-devel-0.6.33-1.el7.x86_64.rpm --d1 libsolv-debuginfo-0.6.26-2.el7.x86_64.rpm --d2 libsolv-debuginfo-0.6.33-1.el7.x86_64.rpm
================ changes of 'libsolv.so.0'===============
  Functions changes summary: 2 Removed, 1 Changed (69 filtered out), 5 Added functions
  Variables changes summary: 0 Removed, 0 Changed, 0 Added variable

  2 Removed functions:

    'function void solver_disableproblem(Solver*, Id)'    {solver_disableproblem@@SOLV_1.0}
    'function void solver_enableproblem(Solver*, Id)'    {solver_enableproblem@@SOLV_1.0}

  5 Added functions:

    'function void map_invertall(Map*)'    {map_invertall@@SOLV_1.2}
    'function void pool_best_solvables(Pool*, Queue*, int)'    {pool_best_solvables@@SOLV_1.1}
    'function void pool_set_whatprovides(Pool*, Id, Id)'    {pool_set_whatprovides@@SOLV_1.2}
    'function void selection_subtract(Pool*, Queue*, Queue*)'    {selection_subtract@@SOLV_1.2}
    'function void solver_get_cleandeps(Solver*, Queue*)'    {solver_get_cleandeps@@SOLV_1.1}

  1 function with some indirect sub-type change:

    [C]'function void policy_filter_unwanted(Solver*, Queue*, int)' at policy.c:1312:1 has some indirect sub-type changes:
      parameter 1 of type 'Solver*' has sub-type changes:
        in pointed to type 'typedef Solver' at solver.h:214:1:
          underlying type 'struct _Solver' at solver.h:29:1 changed:
            type size hasn't changed
            1 data member deletion:
              'int _Solver::dupmap_all', at offset 7296 (in bits) at solver.h:171:1

            3 data member insertions:
              'Id _Solver::bestrules_up', at offset 1344 (in bits) at solver.h:71:1
              'int _Solver::process_orphans', at offset 7136 (in bits) at solver.h:171:1
              'int _Solver::dupinvolvedmap_all', at offset 7424 (in bits) at solver.h:174:1
            6 data member changes (1 filtered):
             'Id _Solver::bestrules_end' offset changed from 1344 to 1376 (in bits) (by +32 bits)
             'Map _Solver::dupinvolvedmap' offset changed from 7360 to 7296 (in bits) (by -64 bits)
             'int _Solver::dup_allowdowngrade' offset changed from 7488 to 7456 (in bits) (by -32 bits)
             'int _Solver::dup_allownamechange' offset changed from 7520 to 7488 (in bits) (by -32 bits)
             'int _Solver::dup_allowarchchange' offset changed from 7552 to 7520 (in bits) (by -32 bits)
             'int _Solver::dup_allowvendorchange' offset changed from 7584 to 7552 (in bits) (by -32 bits)



================ end of changes of 'libsolv.so.0'===============



The removal of 2 symbols should not be a problem because they were not in any headers and no one could really use them.

Comment 5 Valentina Mukhamedzhanova 2018-04-03 11:49:39 UTC
*** Bug 1561340 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2018-10-30 11:26:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3234


Note You need to log in before you can comment on or make changes to this bug.