Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513550 - Support tagging
Summary: Support tagging
Keywords:
Status: CLOSED DUPLICATE of bug 1684676
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 15:34 UTC by Ken Gaillot
Modified: 2019-03-05 11:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-05 11:01:03 UTC


Attachments (Terms of Use)

Description Ken Gaillot 2017-11-15 15:34:06 UTC
Pacemaker supports tagging of XML elements:

http://clusterlabs.org/doc/en-US/Pacemaker/1.1-pcs/html-single/Pacemaker_Explained/index.html#_tagging_configuration_elements

This will be important for pcs primarily for nodes and resources, because tagging is expected to be part of the solution for Bug 1300597 and Bug 1300604. The idea is that the user will be able to tag certain nodes and/or resources, then use (not yet implemented) options to crm_mon to display the status of just those.

An example of how it might eventually work:

pcs resource tag myrsc1 special
pcs resource create myrsc2 Dummy --tag special
pcs status --resources=special # shows status of myrsc1 and myrsc2 only

This bz is just for the tagging functionality, which is already supported by pacemaker. A separate bz will be opened for the pcs status functionality once the crm_mon interface is finalized.

I can imagine tagging coming in handy in other situations in the future. Pacemaker implements tags mainly for UI use, so feel free to use tags elsewhere in pcs for any purpose.

Comment 2 Ken Gaillot 2017-11-15 15:42:43 UTC
FYI, because tags are XML IDs, they are guaranteed to be unique with respect to resource names and node IDs (sadly, not node names). That gives you the option of accepting tag names wherever a resource name can be used, rather than requiring a special syntax in that situation.

Comment 3 Jan Pokorný [poki] 2017-11-15 15:48:40 UTC
See also bottom of [bug 1441332 comment 5] + a link from the subsequent
comment.

Comment 4 Tomas Jelinek 2019-03-05 11:01:03 UTC
This feature is unlikely to be implemented in RHEL 7 due to its high complexity and demand on resources. Since there is already a RHEL 8 bz for the same feature, I am closing this as a duplicate.

*** This bug has been marked as a duplicate of bug 1684676 ***


Note You need to log in before you can comment on or make changes to this bug.