Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513510 - DVR deployments fail
Summary: DVR deployments fail
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 12.0 (Pike)
Assignee: Brent Eagles
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 14:39 UTC by Arie Bregman
Modified: 2018-01-25 09:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-25 09:35:30 UTC


Attachments (Terms of Use)

Description Arie Bregman 2017-11-15 14:39:07 UTC
Description of problem:

We deploy DVR deployments by using the following line (in addition to DVR environment file):

OS::TripleO::Compute::Ports::ExternalPort: /usr/share/openstack-tripleo-heat-templates/network/ports/external.yaml

but external.yaml no longer exists so we get a failure it's missing

At some point, it was suggested that we remove external.yaml include since it's rendered and automatically enabled when network isolation is used, but it still fails for us even after removing this line (you can have a look at the artifacts in next comment).

Version-Release number of selected component (if applicable): Director 12 latest


How reproducible: 100%


Steps to Reproduce:
1. Deploy Director 12 with DVR enabled


Note You need to log in before you can comment on or make changes to this bug.