Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513491 - SSUI: Language selection of SSUI login page not working anymore
Summary: SSUI: Language selection of SSUI login page not working anymore
Keywords:
Status: CLOSED DUPLICATE of bug 1507578
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: GA
: 5.9.0
Assignee: Chris Hale
QA Contact: Yadnyawalk Tale
URL:
Whiteboard: ui:ssui
Depends On: 1507578
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 14:17 UTC by Satoe Imaishi
Modified: 2018-02-09 15:12 UTC (History)
7 users (show)

Fixed In Version: 5.9.0.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1507578
Environment:
Last Closed: 2018-02-09 15:12:15 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)
not_working_screenshot (deleted)
2017-12-12 13:19 UTC, Yadnyawalk Tale
no flags Details

Comment 2 CFME Bot 2017-11-29 20:30:41 UTC
New commit detected on ManageIQ/manageiq-ui-service/gaprindashvili:
https://github.com/ManageIQ/manageiq-ui-service/commit/74cb454aa66f9ec81b00a8a5d0968702918199b0

commit 74cb454aa66f9ec81b00a8a5d0968702918199b0
Author:     Chris Kacerguis <chriskacerguis@users.noreply.github.com>
AuthorDate: Fri Nov 10 15:13:03 2017 -0600
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Wed Nov 15 09:18:40 2017 -0500

    Merge pull request #1233 from chalettu/language-login-bug
    
    Fixed issue with language not saving
    (cherry picked from commit 8733dcc93c80f891dd3bb07e65f5c620264d17dc)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1513491

 client/app/core/language.service.js | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 3 Yadnyawalk Tale 2017-12-12 13:19:19 UTC
Created attachment 1366650 [details]
not_working_screenshot

Tested on 5.9.0.12, not working at all! 

Initially, I thought there might be no translation available for language; but when I tried with Administrator > Switch Language > `Language` it worked, that means selection upon login only not working!

Tried with all languages, I thought earlier English language pages might get cached, so I spawn 9 new appliances and checked single-language on fresh single-appliance with cleared cache, but none of this worked! 

I am also wondering why this is happening!

Comment 4 Chris Hale 2018-02-09 15:12:15 UTC
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1507578.  I am closing this issue.

*** This bug has been marked as a duplicate of bug 1507578 ***


Note You need to log in before you can comment on or make changes to this bug.