Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513467 - IPA upgrade fails for latest ipa package
Summary: IPA upgrade fails for latest ipa package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: Viktor Ashirov
URL:
Whiteboard:
: 1512894 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 13:15 UTC by Nikhil Dehadrai
Modified: 2018-04-10 14:23 UTC (History)
10 users (show)

Fixed In Version: 389-ds-base-1.3.7.5-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 14:22:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0811 None None None 2018-04-10 14:23:27 UTC

Description Nikhil Dehadrai 2017-11-15 13:15:04 UTC
Description of problem:
IPA upgrade fails for latest ipa package, when upgraded from RHEL 7.3.z > RHEL 7.5

Version-Release number of selected component (if applicable):
ipa-server-4.5.4-4.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Setup ipa-server at version RHEL 7.3.z
2.configure latest repo for RHel 7.5
3.upgrade the ipa using command
# yum - y update 'ipa*' sssd

Actual results:
IPA upgrade fails with following message

IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
Unexpected error - see /var/log/ipaupgrade.log for details:
CalledProcessError: Command '/bin/systemctl start dirsrv@TESTRELM-TEST.service' returned non-zero exit status 1
The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information

#[root@vm-idm-005 ~]# tail -30 /var/log/ipaupgrade.log
2017-11-15T13:04:02Z DEBUG Loading StateFile from '/var/lib/ipa/sysrestore/sysrestore.state'
2017-11-15T13:04:02Z DEBUG Saving StateFile to '/var/lib/ipa/sysrestore/sysrestore.state'
2017-11-15T13:04:02Z DEBUG Loading StateFile from '/var/lib/ipa/sysrestore/sysrestore.state'
2017-11-15T13:04:02Z DEBUG   duration: 0 seconds
2017-11-15T13:04:02Z ERROR IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
2017-11-15T13:04:02Z DEBUG   File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 172, in execute
    return_value = self.run()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/ipa_server_upgrade.py", line 46, in run
    server.upgrade()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1902, in upgrade
    data_upgrade.create_instance()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/upgradeinstance.py", line 124, in create_instance
    runtime=90)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/service.py", line 504, in start_creation
    run_step(full_msg, method)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/service.py", line 494, in run_step
    method()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/upgradeinstance.py", line 95, in __start
    srv.start(self.serverid, ldapi=True)
  File "/usr/lib/python2.7/site-packages/ipaplatform/redhat/services.py", line 157, in start
    instance_name, capture_output=capture_output, wait=wait)
  File "/usr/lib/python2.7/site-packages/ipaplatform/base/services.py", line 294, in start
    skip_output=not capture_output)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 523, in run
    raise CalledProcessError(p.returncode, arg_string, str(output))
 
2017-11-15T13:04:02Z DEBUG The ipa-server-upgrade command failed, exception: CalledProcessError: Command '/bin/systemctl start dirsrv@TESTRELM-TEST.service' returned non-zero exit status 1
2017-11-15T13:04:02Z ERROR Unexpected error - see /var/log/ipaupgrade.log for details:
CalledProcessError: Command '/bin/systemctl start dirsrv@TESTRELM-TEST.service' returned non-zero exit status 1
2017-11-15T13:04:02Z ERROR The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information

Expected results:
IPA upgrade should be successful

Additional info:
The same upgrade is successful from following paths:
1) RHEL 7.4-0day > RHEL 7.5
2) RHEL 7.4.3 > RHEL 7.5

Comment 10 Florence Blanc-Renaud 2017-11-17 10:41:25 UTC
*** Bug 1512894 has been marked as a duplicate of this bug. ***

Comment 12 Nikhil Dehadrai 2017-11-20 12:52:47 UTC
IPA server version: ipa-server-4.5.4-4.el7.x86_64
DS package: 389-ds-base-1.3.7.5-10.el7.x86_64

Verified the bug on the basis of following observations:
1. Verified that IPA server upgrade from RHEL 7.3.z > RHEL 7.5 is now successful.

2. No Failures / Errors as mentioned inside the bug are observed inside /var/log/ipaupgrade.log.

3. Verified that ""cn=Legacy Replication Plugin,cn=plugins,cn=config" plugin is removed after upgrade.

4. All the commands run successfully after upgrade:
# ipactl status
# ipactl restart
# kinit <user>

Thus on the basis of above observations, marking status of this bug to "VERIFIED"

Comment 15 errata-xmlrpc 2018-04-10 14:22:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811


Note You need to log in before you can comment on or make changes to this bug.