Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513465 - The message "The disk for database must be a mount point" makes no sense
Summary: The message "The disk for database must be a mount point" makes no sense
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.9.0
Assignee: Gregg Tanzillo
QA Contact: luke couzens
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 13:13 UTC by Jaroslav Henner
Modified: 2019-01-17 13:11 UTC (History)
9 users (show)

Fixed In Version: 5.9.0.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 15:10:47 UTC
Category: ---
Cloudforms Team: Container Management
jhenner: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1508958 None VERIFIED Missleading error when create internal database without any unpartitioned disk available 2019-01-17 13:11:45 UTC

Internal Links: 1508958

Description Jaroslav Henner 2017-11-15 13:13:20 UTC
Description of problem:
Trying to set a internal DB on APPLIANCE
ssh root@$APPLIANCE TERM=rxvt appliance_console_cli \
 --region 1 \
 --internal \
 -p foo \
 --dbdisk /dev/foo/bar/baz

I get
Warning: Permanently added '10.8.246.34' (ECDSA) to the list of known hosts.
configuring internal database
The disk for database must be a mount point
Failed to configure internal database


This message doesn't make sense because
```
A mount point is a directory (typically an empty one) in the currently accessible filesystem on which an additional filesystem is mounted (i.e., logically attached). A filesystem is a hierarchy of directories (also referred to as a directory tree) that is used to organize files on a computer system.Mar 4, 2006
Mount point definition by The Linux Information Project
www.linfo.org/mount_point.html
```

whereas the disk is a block device (hence not a directory), usualy in /dev/.

That means that disk cannot be a mount point. So the message is contradictory.


Version-Release number of selected component (if applicable):
cfme-rhos-5.9.0.8 

How reproducible:
always

Steps to Reproduce:
1. do the stuff written in description
2.
3.

Actual results:
contradictory message  to stdout

Expected results:
some sane message of what was wrong, maybe rather to stderr

Additional info:

Comment 2 Jaroslav Henner 2017-11-15 13:14:30 UTC
This happens also in appliance_console:

Are you sure you don't want to partition the database disk? (Y/N): y
Configuration failed: The disk for database must be a mount point

Comment 3 Yuri Rudman 2017-12-11 19:49:44 UTC
this issue addressed by PR: https://github.com/ManageIQ/manageiq-appliance_console/pull/16

Comment 4 Jaroslav Henner 2017-12-12 03:21:04 UTC
Maybe I should reframe the bug. The problem actually is deeper:
 * IIRC the utility expects device-file of certain name. This is not good.
 * Why not to utilize the sysfs and allow device of any name? Try ls /sys/class/block/

 Then we (the qe) had easier life to create the device for tests

`--> truncate -s1M /tmp/foo 
`--> sudo losetup -f /tmp/foo
.`--> ll /sys/class/block 
total 0
...
lrwxrwxrwx. 1 root root 0 12. pro 04.15 loop0 -> ../../devices/virtual/block/loop0
...

Please stop throwing rocks under the legs of people who want to manage things. You can have some safe default or something and some big red warning.

Thanks for paying attention to this problem.

Comment 5 Yuri Rudman 2017-12-12 15:38:42 UTC
(In reply to Jaroslav Henner from comment #4)
> Maybe I should reframe the bug. The problem actually is deeper:
>  * IIRC the utility expects device-file of certain name. This is not good.
>  * Why not to utilize the sysfs and allow device of any name? Try ls
> /sys/class/block/
> 

Yes, I would suggest to rephrase BZ title or (may be better) create another BZ, since current bug Description and Expected result supposed to be addressed by above mentioned PR.

Comment 6 Yuri Rudman 2018-01-16 14:24:19 UTC
Jaroslav,

Could you create new BZ or [RFE] with more details (in regards to Comment 4).

Issue described in this one addressed by  https://github.com/ManageIQ/manageiq-appliance_console/pull/16


Note You need to log in before you can comment on or make changes to this bug.