Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513456 - 3.12.10 release is available
Summary: 3.12.10 release is available
Keywords:
Status: CLOSED DUPLICATE of bug 1519323
Alias: None
Product: Fedora
Classification: Fedora
Component: qesteidutil
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 12:41 UTC by Germano Massullo
Modified: 2017-11-30 17:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-30 17:39:15 UTC


Attachments (Terms of Use)

Description Germano Massullo 2017-11-15 12:41:47 UTC
Description of problem:
3.12.9 release is available. Updates should be pushed ASAP because of the recent events concerning Eeste ID security [*]
https://github.com/open-eid/qesteidutil/releases/tag/v3.12.9

https://arstechnica.com/information-technology/2017/10/crypto-failure-cripples-millions-of-high-security-keys-750k-estonian-ids/

Comment 1 Germano Massullo 2017-11-28 18:30:48 UTC
I have tried to bump the release of F25 spec file (F26 branch is marked as orphan so it does not have any file) and I tried to run a rpm mock build on 3.12.10 release against F26, but the patches do not fit so they require to be checked against 3.12.10 version.
Unfortunately I did not have time to do such work.
For information completeness I attach mock logs

[...]
Execution(%prep) in progress: /bin/sh -e /var/tmp/rpm-tmp.boDDIQ
+ umask 022
+ cd /builddir/build/BUILD
+ cd /builddir/build/BUILD
+ rm -rf qesteidutil-3.12.10
+ /usr/bin/gzip -dc /builddir/build/SOURCES/qesteidutil-3.12.10.tar.gz
+ /usr/bin/tar -xof -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd qesteidutil-3.12.10
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
Patch #0 (sandbox-compilation.patch):
+ echo 'Patch #0 (sandbox-compilation.patch):'
+ /usr/bin/patch --no-backup-if-mismatch -p1 --fuzz=0
patching file common/CMakeLists.txt
Patch #1 (openssl_v1.1.patch):
+ echo 'Patch #1 (openssl_v1.1.patch):'
+ /usr/bin/patch --no-backup-if-mismatch -p1 --fuzz=0
patching file common/SslCertificate.cpp
Hunk #1 FAILED at 33.
Hunk #2 FAILED at 86.
Hunk #3 FAILED at 137.
Hunk #4 FAILED at 173.
Hunk #5 FAILED at 276.
Hunk #6 FAILED at 328.
6 out of 6 hunks FAILED -- saving rejects to file common/SslCertificate.cpp.rej
patching file src/QSmartCard.cpp
Hunk #1 FAILED at 212.
Hunk #2 FAILED at 266.
Hunk #3 FAILED at 303.
3 out of 3 hunks FAILED -- saving rejects to file src/QSmartCard.cpp.rej
patching file src/QSmartCard_p.h
Hunk #1 FAILED at 47.
1 out of 1 hunk FAILED -- saving rejects to file src/QSmartCard_p.h.rej
patching file src/Updater.cpp
Hunk #1 FAILED at 52.
Hunk #2 FAILED at 221.
Hunk #3 FAILED at 443.
3 out of 3 hunks FAILED -- saving rejects to file src/Updater.cpp.rej
errore: Stato d'uscita errato da /var/tmp/rpm-tmp.boDDIQ (%prep)


RPM errors:
    Wrong exit status from /var/tmp/rpm-tmp.boDDIQ (%prep)
ERROR: Exception(/home/caterpillar/rpmbuild/SRPMS/qesteidutil-3.12.10-1.fc26.src.rpm) Config(fedora-26-x86_64) 15 minutes 52 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-26-x86_64/result
ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M c360ec0879a249caacc62be10054fc59 -D /var/lib/mock/fedora-26-x86_64/root -a --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/builddir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=it_IT.UTF-8 -u mockbuild bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps /builddir/build/SPECS/qesteidutil.spec

Comment 2 Germano Massullo 2017-11-30 17:39:15 UTC

*** This bug has been marked as a duplicate of bug 1519323 ***


Note You need to log in before you can comment on or make changes to this bug.