Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513453 - Not all actions are logged in the debug log
Summary: Not all actions are logged in the debug log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Honza Pokorny
QA Contact: Udi
URL:
Whiteboard:
Depends On: 1568743
Blocks: 1386306
TreeView+ depends on / blocked
 
Reported: 2017-11-15 12:29 UTC by Udi
Modified: 2018-06-27 13:39 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1733633 None None None 2017-11-21 16:09:12 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:48 UTC
OpenStack gerrit 541079 None master: MERGED tripleo-common: Refactor GUI logging to use message claims (Ie8d1762b3c61ff96ef8b4d32e15e758ef2f618d3) 2018-03-21 13:32:40 UTC

Description Udi 2017-11-15 12:29:25 UTC
Description of problem:
The debug log in the UI should show every action and every error that the user got. A lot of actions are not logged, for example: trying to introspect an "available" node and getting an error (because it should be made "manageable" first).


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.3-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Try to introspect a node which is already provided (it's in "available" state).
2. After getting the error message, download the logs and try to find this event in them.


Actual results:
The action and the error you just produced don't appear in the log.

Comment 10 errata-xmlrpc 2018-06-27 13:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.