Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513355 - [abrt] [faf] Crash under soup_socket_new()
Summary: [abrt] [faf] Crash under soup_socket_new()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libsoup
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Milan Crha
QA Contact: Desktop QE
URL: http://faf.lab.eng.brq.redhat.com/faf...
Whiteboard:
: 1446084 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 09:39 UTC by Vladimir Benes
Modified: 2019-03-07 16:33 UTC (History)
5 users (show)

Fixed In Version: libsoup-2.56.0-6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 10:32:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0703 None None None 2018-04-10 10:33:07 UTC
GNOME Bugzilla 762138 None None None 2017-11-15 14:43:26 UTC

Description Vladimir Benes 2017-11-15 09:39:38 UTC
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/c7a33882289b5649a7be13634b0b911c1884d370/

We still don't have exact reproducer as it's probably quite rare race but we see it here and there and it's still with us. So I am filling it just for tracking purposes.

Comment 1 Milan Crha 2017-11-15 14:43:27 UTC
Related Fedora bug #1458498 and upstream bug [1] with a reproducer and proposed patch.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=762138

Comment 6 errata-xmlrpc 2018-04-10 10:32:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0703

Comment 7 Milan Crha 2019-03-07 16:33:35 UTC
*** Bug 1446084 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.