Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513347 - Fedora 26 gnome-shell crashes at boot
Summary: Fedora 26 gnome-shell crashes at boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 09:23 UTC by Herbert
Modified: 2018-02-13 09:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-13 09:32:16 UTC


Attachments (Terms of Use)

Description Herbert 2017-11-15 09:23:07 UTC
Description of problem:
During boot the following problem arises: gnome-shell crashes.
Note: No monitor (display) nor a keyboard connected.

Version-Release number of selected component (if applicable):
gnome-shell.x86_64 3.24.3-2.fc26

How reproducible:
reboot

Steps to Reproduce:
1.
2.
3.

Actual results:
dmesg

[ 28.252916] gnome-shell[1717]: segfault at 28 ip 00007fa08013bb74 sp 00007ffe5f11c4e0 error 4 in libmutter-0.so.0.0.0[7fa0800ec000+13a000]
[ 31.512996] gnome-shell[1895]: segfault at 28 ip 00007fac6b384b74 sp 00007ffd8d62c7a0 error 4 in libmutter-0.so.0.0.0[7fac6b335000+13a000]
[ 34.227978] gnome-shell[2010]: segfault at 28 ip 00007f4963e2eb74 sp 00007ffe54f97c00 error 4 in libmutter-0.so.0.0.0[7f4963ddf000+13a000]
[ 36.959938] gnome-shell[2123]: segfault at 28 ip 00007fbce54afb74 sp 00007ffc691b46f0 error 4 in libmutter-0.so.0.0.0[7fbce5460000+13a000]
[ 41.497656] gnome-shell[2367]: segfault at 28 ip 00007f7db8b53b74 sp 00007fff2deb7780 error 4 in libmutter-0.so.0.0.0[7f7db8b04000+13a000]
[ 42.454135] gnome-shell[2381]: segfault at 28 ip 00007fc647d86b74 sp 00007fffac3c6050 error 4 in libmutter-0.so.0.0.0[7fc647d37000+13a000]

and

coredumpctl info 1348

PID: 1348 (gnome-shell)
UID: 42 (gdm)
GID: 42 (gdm)
Signal: 11 (SEGV)
Timestamp: Tue 2017-11-14 14:08:04 CET (4h 49min ago)
Command Line: /usr/bin/gnome-shell
Executable: /usr/bin/gnome-shell
Control Group: /user.slice/user-42.slice/session-c1.scope
Unit: session-c1.scope
Slice: user-42.slice
Session: c1
Owner UID: 42 (gdm)
Boot ID: 5d41fa6eefd94ff284075a55dc1f3b99
Machine ID: e7b78b4b388a4e4aa3cb458ec919077a
Hostname: udoo.symmetrix.ch
Storage: /var/lib/systemd/coredump/core.gnome-shell.42.5d41fa6eefd94ff284075a55dc1f3b99.1348.151 0664884000000.lz4
Message: Process 1348 (gnome-shell) of user 42 dumped core.

Stack trace of thread 1348:
#0 0x00007fe0ec560b74 center_pointer (libmutter-0.so.0)
#1 0x00007fe0ec5eab8f meta_backend_native_post_init (libmutter-0.so.0)
#2 0x00007fe0ec59fcc6 meta_init (libmutter-0.so.0)
#3 0x00005647a5b111aa main (gnome-shell)
#4 0x00007fe0e5f9c88a __libc_start_main (libc.so.6)
#5 0x00005647a5b115ba _start (gnome-shell)

Stack trace of thread 1414:
#0 0x00007fe0e6080d2d poll (libc.so.6)
#1 0x00007fe0e7b66569 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
#2 0x00007fe0e7b6667c g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007fe0e7b666c1 glib_worker_main (libglib-2.0.so.0)
#4 0x00007fe0e7b8d536 g_thread_proxy (libglib-2.0.so.0)
#5 0x00007fe0e635836d start_thread (libpthread.so.0)
#6 0x00007fe0e608ce1f __clone (libc.so.6)

Stack trace of thread 1424:
#0 0x00007fe0e6080d2d poll (libc.so.6)
#1 0x00007fe0e7b66569 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
#2 0x00007fe0e7b66902 g_main_loop_run (libglib-2.0.so.0)
#3 0x00007fe0e968ccb6 gdbus_shared_thread_func (libgio-2.0.so.0)
#4 0x00007fe0e7b8d536 g_thread_proxy (libglib-2.0.so.0)
#5 0x00007fe0e635836d start_thread (libpthread.so.0)
#6 0x00007fe0e608ce1f __clone (libc.so.6)

Stack trace of thread 1488:
#0 0x00007fe0e60877b9 syscall (libc.so.6)
#1 0x00007fe0e7bab6fa g_cond_wait_until (libglib-2.0.so.0)
#2 0x00007fe0e7b3ab31 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0)
#3 0x00007fe0e7b8ded4 g_thread_pool_thread_proxy (libglib-2.0.so.0)
#4 0x00007fe0e7b8d536 g_thread_proxy (libglib-2.0.so.0)
#5 0x00007fe0e635836d start_thread (libpthread.so.0)
#6 0x00007fe0e608ce1f __clone (libc.so.6)

Stack trace of thread 1518:
#0 0x00007fe0e6080d2d poll (libc.so.6)
#1 0x00007fe0e7b66569 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
#2 0x00007fe0e7b6667c g_main_context_iteration (libglib-2.0.so.0)
#3 0x00007fe0c8e3ef3d dconf_gdbus_worker_thread (libdconfsettings.so)
#4 0x00007fe0e7b8d536 g_thread_proxy (libglib-2.0.so.0)
#5 0x00007fe0e635836d start_thread (libpthread.so.0)
#6 0x00007fe0e608ce1f __clone (libc.so.6)

Expected results:
No errors or crashes.


Additional info:

Comment 1 Herbert 2017-11-15 17:39:34 UTC
uname -a
Linux udoo.symmetrix.ch 4.13.12-200.fc26.x86_64 #1 SMP Wed Nov 8 16:47:26 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Comment 2 Herbert 2017-11-19 10:15:27 UTC
lspci -nnk |grep -A 3 -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller [8086:22b1] (rev 35)
        Subsystem: Intel Corporation Device [8086:7270]
        Kernel driver in use: i915
        Kernel modules: i915

Comment 3 Vanoywj 2017-12-23 06:48:36 UTC
Description of problem: In Journalctl the following message appears:

Steps to reproduce: 1. Select Fedora 26 from grub menu
                    2. Allows boot to Gnome GUI
                    3. Login and run 'journalctl -b -p3 | less'

Actual results:
Running 'journalctl -b -p3 | less' the following message appears for the crash,


The stack error runs as follows,
gnome-session-binary[1036]: Unrecoverable failure in required component org.gnome.Shell.desktop
systemd-coredump[1210]: Process 1174 (gnome-shell) of user 42 dumped core.
                                                     
                                                     Stack trace of thread 1174:
                                                     #0  0x00007f15858a7b74 center_pointer (libmutter-0.so.0)
                                                     #1  0x00007f1585931b8f meta_backend_native_post_init (libmutter-0.so.0)
                                                     #2  0x00007f15858e6cc6 meta_init (libmutter-0.so.0)
                                                     #3  0x000055b6a44751aa main (gnome-shell)
                                                     #4  0x00007f157f2e288a __libc_start_main (libc.so.6)
                                                     #5  0x000055b6a44755ba _start (gnome-shell)
                                                     
                                                     Stack trace of thread 1208:
                                                     #0  0x00007f157f3c6d2d poll (libc.so.6)
                                                     #1  0x00007f1580ead579 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
                                                     #2  0x00007f1580ead68c g_main_context_iteration (libglib-2.0.so.0)
                                                     #3  0x00007f1556574f3d dconf_gdbus_worker_thread (libdconfsettings.so)
                                                     #4  0x00007f1580ed4516 g_thread_proxy (libglib-2.0.so.0)
                                                     #5  0x00007f157f69e36d start_thread (libpthread.so.0)
                                                     #6  0x00007f157f3d2e1f __clone (libc.so.6)
                                                     
                                                     Stack trace of thread 1178:
                                                     #0  0x00007f157f3c6d2d poll (libc.so.6)
                                                     #1  0x00007f1580ead579 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
                                                     #2  0x00007f1580ead68c g_main_context_iteration (libglib-2.0.so.0)
                                                     #3  0x00007f1580ead6d1 glib_worker_main (libglib-2.0.so.0)
                                                     #4  0x00007f1580ed4516 g_thread_proxy (libglib-2.0.so.0)
                                                     #5  0x00007f157f69e36d start_thread (libpthread.so.0)
                                                     #6  0x00007f157f3d2e1f __clone (libc.so.6)
                                                     
                                                     Stack trace of thread 1205:
                                                     #0  0x00007f157f3cd7b9 syscall (libc.so.6)
#1  0x00007f1580ead579 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
                                                     #2  0x00007f1580ead912 g_main_loop_run (libglib-2.0.so.0)
                                                     #3  0x00007f15829d3db6 gdbus_shared_thread_func (libgio-2.0.so.0)
                                                     #4  0x00007f1580ed4516 g_thread_proxy (libglib-2.0.so.0)
                                                     #5  0x00007f157f69e36d start_thread (libpthread.so.0)
                                                     #6  0x00007f157f3d2e1f __clone (libc.so.6)
                                                     
                                                     Stack trace of thread 1206:
                                                     #0  0x00007f157f6a490b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
                                                     #1  0x00007f155ac2114b util_queue_thread_func (nouveau_dri.so)
                                                     #2  0x00007f155ac21067 impl_thrd_routine (nouveau_dri.so)
                                                     #3  0x00007f157f69e36d start_thread (libpthread.so.0)
                                                     #4  0x00007f157f3d2e1f __clone (libc.so.6)


There is a further message,
abrt-notification[1756]: Process 1174 (gnome-shell) crashed in center_pointer()

Expected result: Run as normal, no gnome-shell crash error in journalctl

Additional info:
Linux 4.14.4-200.fc26.x86_64 #1 SMP Fri Dec 8 20:37:31 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 420M] [10de:0df1] (rev a1)
	Subsystem: Samsung Electronics Co Ltd Device [144d:c08e]
	Kernel driver in use: nouveau
	Kernel modules: nouveau

Comment 4 Herbert 2018-02-13 09:32:16 UTC
Seems to be fixed now after kernel update to:

# uname -a
Linux 4.14.18-200.fc26.x86_64 #1 SMP Thu Feb 8 01:35:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


Note You need to log in before you can comment on or make changes to this bug.