Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513339 - Awesome window manager doesn't start with Fedora Desktop 27 without a workaround
Summary: Awesome window manager doesn't start with Fedora Desktop 27 without a workaround
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 09:04 UTC by Pekka Enberg
Modified: 2018-11-30 18:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 18:54:13 UTC


Attachments (Terms of Use)

Description Pekka Enberg 2017-11-15 09:04:18 UTC
Description of problem:

I installed Fedora Workstation 27 from scratch. I then logged into GNOME desktop and installed Awesome window manager with "dnf install awesome". After rebooting the machine, login screen has a "awesome" option, which I selected. However, the default GNOME desktop starts regarldess of the selection.

To make it work, I found the following blog post:

https://makandracards.com/makandra/1367-running-the-awesome-window-manager-within-gnome

It was sufficient to just create the "/usr/share/applications/awesome.desktop" file to make Awesome window manager start correctly:

[Desktop Entry]
Version=1.0
Type=Application
Name=awesome
TryExec=awesome
Exec=awesome

How reproducible:

Always.

Steps to Reproduce:
1. "dnf install awesome" 
2. Restart machine
3. Login with "awesome" window manager selected

Actual results:

Regular GNOME desktop starts.

Expected results:

Awesome window manager should start.

Comment 1 Baoquan He 2017-12-11 10:23:58 UTC
Hi Pekka,

I have been using awesome and it's pretty good and convenient for my programming and browsing, and I found it also doesn't work on my f27 and f26. Though I added /usr/share/applications/awesome.desktop as you said, it still doesn't work. No idea how to make it work.

I rely on this wm very much.

Comment 2 Thomas Moschny 2017-12-12 10:56:59 UTC
Tried to reproduce the issue, unfortunately without success. I have a machine that I recently upgraded from F26 to F27, installed awesome, rebooted, selected "awesome" in gdm, and awesome works - however that is a rather 'pure' awesome environment, without gnome services.

Comment 3 Baoquan He 2017-12-12 11:07:29 UTC
I just installed from a workstation x86 64 iso, and the software defaults to be chosen. After installation, rebooted, no awesome. dnf install awesome, logout or reboot, awesome is in the wm choice and chosen when login, but still drop to gnome.

I tried ways the post Pekka mentioned, just copied and generated those files related to gnome3, rebooted several times, it finally works. I don't know why. And have not time to dig further since there's task at hand.

Comment 4 Thomas Moschny 2017-12-15 15:26:03 UTC
So, I experimented with a fresh VM, and I suspect a GDM bug here.

Let me explain. The selected environment is stored in /var/lib/AccountsService/users/<username>, in the key XSession (in the [User] section).

Now, for a fresh install, the value for that key is empty - and for an empty value, GDM defaults to the standard GNOME Environment.

When awesome is installed, an entry for it is added to the list that can be reached by pressing the gear on the GDM login screen, and GDM displays a big dot before it, suggesting awesome would be the selected WM. But that is false, it will start GNOME instead.

To make it work, you have to explicitly select a different WM first (e.g. GNOME), log-in, log out, select awesome again, and then log-in.

Or put it the other way round, awesome will only start if Xession=awesome is set in /var/lib/AccountsService/users/<username>.

To make it clear, the GDM bug is imho that an empty value for XSession means it will default to GNOME, but the menu will display a big dot elsewhere (I guess on the first entry).

Comment 5 Baoquan He 2017-12-16 00:17:47 UTC
Seems yes. I did as the post said, still didn't work. But a new gnome-awesome appeared. So I selected gnome-awesome, didn't work, then select back awesome, works.

Thanks, Thomas.

Comment 6 Ben Cotton 2018-11-27 17:42:55 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 7 Ben Cotton 2018-11-30 18:54:13 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.