Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513317 - loopback IP is used in F5 BIG-IP LBaaS Plug-in and there is a conflict when run the certification test
Summary: loopback IP is used in F5 BIG-IP LBaaS Plug-in and there is a conflict when ...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 07:44 UTC by jinhua li
Modified: 2018-06-06 13:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-06 13:45:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1675785 None None None 2018-04-16 16:25:45 UTC

Description jinhua li 2017-11-15 07:44:42 UTC
There is a related bug: https://bugs.launchpad.net/octavia/+bug/1675785
When F5 team run the certification test, below test items would fail because of the loopback IP(127.0.0)using in below files:

neutron_lbaas/tests/tempest/v2/ddt/base_ddt.py
neutron_lbaas/tests/tempest/v2/api/test_members_admin.py
neutron_lbaas/tests/tempest/v2/api/test_members_non_admin.py
neutron_lbaas/tests/unit/services/loadbalancer/test_loadbalancer_plugin.py
neutron_lbaas/tests/unit/db/loadbalancer/test_db_loadbalancerv2.py

Comment 1 jinhua li 2017-11-15 07:45:22 UTC
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_invalid_expected_codes [0.275185s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_invalid_http_method [0.246572s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_invalid_max_retries [0.409075s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_invalid_timeout [0.256074s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_invalid_url_path [0.257856s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_missing_admin_state_up [0.274555s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_missing_expected_codes [0.419046s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_missing_http_method [0.256856s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_missing_max_retries [0.266670s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_missing_timeout [0.249124s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_health_monitors_non_admin.TestHealthMonitors.test_update_health_monitor_missing_url_path [0.266068s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_admin.ListenersTestJSON.test_create_listener_missing_tenant_id [0.103524s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_empty_protocol [0.122224s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_empty_protocol_port [0.129390s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_empty_tenant_id [0.127532s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_incorrect_attribute [0.119921s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_admin_state_up [0.119796s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_connection_limit [0.127039s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_description [0.119927s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_load_balancer_id [0.119576s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_name [0.123815s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_protocol [0.128352s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_protocol_port [0.124782s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_invalid_tenant_id [0.123524s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_missing_admin_state_up [0.100940s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_missing_field_loadbalancer [0.567670s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_missing_field_protocol [0.122691s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_create_listener_missing_field_protocol_port [0.301654s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_listeners_non_admin.ListenersTestJSON.test_list_listeners_two [63.884633s] ... FAILED
{0} setUpClass (neutron_lbaas.tests.tempest.v2.api.test_load_balancers_admin.LoadBalancersTestAdmin) [0.000000s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_admin.MemberTestJSON.test_create_member_invalid_tenant_id [500.002535s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_add_member [500.004730s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_create_member_missing_required_field_tenant_id [0.347576s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_delete_member [0.347338s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_get_member [0.515835s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_list_3_members [500.002124s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_list_empty_members [0.253476s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_raises_exception_on_invalid_attr_on_update [0.360752s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_raises_immutable_when_updating_immutable_attrs_on_member [0.474301s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member [0.347194s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member_empty_admin_state_up [0.332353s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member_empty_weight [0.494445s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member_invalid_admin_state_up [0.671792s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member_invalid_weight [0.356307s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member_missing_admin_state_up [0.359115s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_members_non_admin.MemberTestJSON.test_update_member_missing_weight [0.448376s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_pools_non_admin.TestPools.test_delete_invalid_pool [12.416485s] ... FAILED
{0} neutron_lbaas.tests.tempest.v2.api.test_pools_non_admin.TestPools.test_list_pools_empty [0.290271s] ... FAILED

Comment 3 Nir Magnezi 2018-06-06 13:45:56 UTC
This was widely discussed in bug 1491794 and documented as a kbase article as mentioned in bug 1491794 comment 73.

*** This bug has been marked as a duplicate of bug 1491794 ***


Note You need to log in before you can comment on or make changes to this bug.