Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513284 - [3.5.1]project indices can not be found on kibna UI
Summary: [3.5.1]project indices can not be found on kibna UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-15 05:25 UTC by Junqi Zhao
Modified: 2018-04-12 05:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-12 05:59:07 UTC


Attachments (Terms of Use)
enabled ops cluster, kibana UI, there is not result under .all index (deleted)
2017-11-15 05:25 UTC, Junqi Zhao
no flags Details
disabled ops cluster, kibana UI, although project indices can not be found on kibna UI, project logs can be searched from kibna UI (deleted)
2017-11-15 05:27 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1106 None None None 2018-04-12 05:59:32 UTC

Description Junqi Zhao 2017-11-15 05:25:58 UTC
Created attachment 1352385 [details]
enabled ops cluster, kibana UI, there is not result under .all index

Description of problem:
1. Deploy logging 3.5 without enabled ops cluster and create project, check project logs from kibana. Although project indices can not be found on kibna UI, project logs can be searched from kibna UI


2. Deploy logging 3.5 with enabled ops cluster and create project, check project logs from kibana. Project indices can not be found on kibna UI, and project logs can not be searched from kibna UI, there is not log under .all index,
operation logs can  be searched from kibna-ops UI

both 1 and 2 scenario, project indices are generated.
# oc exec ${es_pod} -- curl -s -k --cert /etc/elasticsearch/secret/admin-cert --key /etc/elasticsearch/secret/admin-key https://logging-es:9200/project.*/_search?size=13\&sort=@timestamp:desc | python -mjson.tool | grep project
                "_index": "project.testing.6cc80ae5-c9ad-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.testing.6cc80ae5-c9ad-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.java.c737f288-c9a9-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.testing.6cc80ae5-c9ad-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.java.c737f288-c9a9-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.install-test.369e900a-c9a7-11e7-9ac3-fa163ef332b3.2017.11.15",
                "_index": "project.install-test.369e900a-c9a7-11e7-9ac3-fa163ef332b3.2017.11.15",
                "_index": "project.testing.6cc80ae5-c9ad-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.java.c737f288-c9a9-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.testing.6cc80ae5-c9ad-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.java.c737f288-c9a9-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.testing.6cc80ae5-c9ad-11e7-a6e2-fa163ef332b3.2017.11.15",
                "_index": "project.java.c737f288-c9a9-11e7-a6e2-fa163ef332b3.2017.11.15",


Version-Release number of selected component (if applicable):

images:
logging-elasticsearch/images/3.5.0-56
logging-kibana/images/3.5.0-51
logging-fluentd/images/3.5.0-46
logging-auth-proxy/images/3.5.0-45
logging-curator/images/v3.5.5.31.47-8

# openshift version
openshift v3.5.5.31.47
kubernetes v1.5.2+43a9be4
etcd 3.1.0

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging 3.5 without enabled ops cluster and create project, check project logs from kibana
2. Deploy logging 3.5 with enabled ops cluster and create project, check project logs from kibana
3.

Actual results:
For step1:. although project indices can not be found on kibna UI, project logs can be searched from kibna UI
For step 2:  project indices can not be found on kibna UI, and project logs can not be searched from kibna UI

Expected results:
For step1:  project indices can be shown on kibna UI
For step 2:  project indices can be shown on kibna UI and project logs can be searched from kibna UI


Additional info:

Comment 1 Junqi Zhao 2017-11-15 05:27:54 UTC
Created attachment 1352386 [details]
disabled ops cluster, kibana UI, although project indices can not be found on kibna UI, project logs can be searched from kibna UI

Comment 4 Junqi Zhao 2017-11-22 08:03:38 UTC
workaround to show project indices
1. Login in kibana UI
2. Go to "settings" -> "indices", "Configure an index pattern" page, add "project.${project_name}*" in "Index name or pattern“ field, select @timestamp from "Time-field name" field. After that, navigate to "Discovery" tab

Comment 5 Anping Li 2017-11-30 10:33:42 UTC
We still couldn't view the index by default when use the stage images
logging-elasticsearch/images/3.5.0-57
logging-auth-proxy/images/3.5.0-45
logging-kibana/images/3.5.0-51
logging-fluentd/images/3.5.0-46

Comment 6 Junqi Zhao 2017-12-01 08:24:52 UTC
Tested with ops and non-ops cluster, project indices could be viewed from kibana UI. But we found another regression bug: https://bugzilla.redhat.com/show_bug.cgi?id=1519694

Images:
logging-elasticsearch-3.5.0-58
logging-auth-proxy-3.5.0-45
logging-kibana-3.5.0-51
logging-fluentd-3.5.0-46
logging-curator-v3.5.5.31.47-10

Please set this defect to ON_QA

Comment 7 Junqi Zhao 2018-03-22 08:21:29 UTC
Enabled ops cluster, project indices can be found and there are logs under .all index on kibana UI


Images
logging-curator-v3.5.5.31.64-1
logging-elasticsearch-3.5.0-62
logging-fluentd-3.5.0-53
logging-kibana-3.5.0-54
logging-auth-proxy-3.5.0-47

Comment 8 Junqi Zhao 2018-03-22 08:22:16 UTC
# openshift version
openshift v3.5.5.31.64
kubernetes v1.5.2+43a9be4
etcd 3.1.0

Comment 11 errata-xmlrpc 2018-04-12 05:59:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1106


Note You need to log in before you can comment on or make changes to this bug.