Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513027 - [RFE]Reads and Writes by Block Size panel is missing
Summary: [RFE]Reads and Writes by Block Size panel is missing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 15:41 UTC by Filip Balák
Modified: 2018-12-07 10:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 10:23:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github Tendrl monitoring-integration issues 150 None None None 2017-11-14 15:41:57 UTC

Description Filip Balák 2017-11-14 15:41:58 UTC
Description of problem:
In specification for Volumes dashboard (https://github.com/Tendrl/specifications/issues/224) in Row 5 is defined panel:

> Panel 26: Reads and Writes by Block Size
> 
> - chart type: Histogram
> - Example:
> - Block Size (x-axis): 1b+ 32b+ 64b+ 128b+ 256b+
> - Read (y-axis): 0 0 0 0 6 Write (y-axis): 908 28 8 5 23

https://github.com/Tendrl/specifications/issues/224#issuecomment-321875857

but in the implemented ui this panel is missing.

Version-Release number of selected component (if applicable):
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. Import cluster with volume and some nodes.
2. Open Volumes dashboard.
3. Look for Reads and Writes by Block Size panel.

Actual results:
The panel is missing.

Comment 1 Nishanth Thomas 2017-11-15 12:42:43 UTC
Above mentioned item is not part of MVP

Comment 2 Martin Bukatovic 2017-11-15 15:48:38 UTC
(In reply to Nishanth Thomas from comment #1)
> Above mentioned item is not part of MVP

Since this "Panel 26: Reads and Writes by Block Size" is part of Row 5 (as stated in the original description of upstream specification issue https://github.com/Tendrl/specifications/issues/224) and later you stated in comment https://github.com/Tendrl/specifications/issues/224#issuecomment-321579201 that:

> Items specified in Row 4,5,6,7 are not MVP.

I believe that you are saying that dev team decided to not implement this feature because it's not included in MVP. Ok.

That said, could you provide me a link to the MVP in question and it's relation to the downstream release of RHGSWA? If you mean this document https://docs.google.com/document/d/10l-MQ_SwZyOj6Jm-gWtC082RR-_HSve3JPrZ_KNCznQ/edit# then you are correct that it doesn't contain any reference to Reads and Writes by Block Size.

Moreover, the discussion continues in the upstream, Ju asked in comment https://github.com/Tendrl/specifications/issues/224#issuecomment-321594230:

> (8) Rows 5, 6, and 7 are all from volume storage profiling that we will be
> enabling/disabling during Import Cluster. This was called out in the Gluster
> Metrics discussion that we would collect this information. If we collect it,
> I was assuming we would be visualizing them.

But I couldn't find a reply for this anywhere. Could you link or provide the answer at least here to make it clear?

I'm sorry that I have to reopen this, but I for downstream, I actually need a clear evidence of a decision which has been made. Nevertheless if this is a future feature, we should keep it open and push it to a different version
anyway.

Comment 3 Nishanth Thomas 2017-11-16 04:28:56 UTC
Currently this data is not collected.Not planning to support until and unless there is a specific ask from PM. Based on feedback from various demos, what we have now is sufficient and even there is an ask to remove certain stats like inode utilization. So this is a nack from development.

Comment 6 Shubhendu Tripathi 2018-11-20 12:50:15 UTC
Do we still need this to be open? I havent seen any ask till now for this.

Comment 7 Nishanth Thomas 2018-12-07 10:23:23 UTC
The grafana dashboard panels underdone multiple rounds of reviews by all stakeholders and I believe this bug is not relevant at the moment. Closing the issue.


Note You need to log in before you can comment on or make changes to this bug.