Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513011 - freetype-devel.i686 caused pkgconf downgrade
Summary: freetype-devel.i686 caused pkgconf downgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1512799
Alias: None
Product: Fedora
Classification: Fedora
Component: pkgconf
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 15:28 UTC by LiZhenbo
Modified: 2017-11-14 15:43 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 15:43:43 UTC


Attachments (Terms of Use)
dnf.log (deleted)
2017-11-14 15:28 UTC, LiZhenbo
no flags Details

Description LiZhenbo 2017-11-14 15:28:35 UTC
Created attachment 1352027 [details]
dnf.log

Description of problem:


Version-Release number of selected component (if applicable):
freetype-devel  i686                   2.8-6.fc27

How reproducible:
Every time

Steps to Reproduce:
1. sudo dnf install  freetype-devel.i686 
2.
3.

Actual results:
Downgrading:
 libpkgconf pkgconf pkgconf-m4 pkgconf-pkg-config

Expected results:


Additional info:
$ rpm -q pkgconf
pkgconf-1.3.10-1.fc27.x86_64
$ rpm -q freetype-devel
freetype-devel-2.8-6.fc27.x86_64

Comment 1 Marek Kašík 2017-11-14 15:42:06 UTC
This looks like a problem in pkgconf. When I remove freetype.i686 and pkgconf.i686 and update, I get pkgconf 1.3.10 x86_64 installed. But once I try to install pkgconf i686 again, it downgrades pkgconf back to 1.3.9 x86_64 and install pkgconf 1.3.9 i686 version.

Comment 2 Igor Gnatenko 2017-11-14 15:43:43 UTC
This has nothing to do with pkgconf.

*** This bug has been marked as a duplicate of bug 1512799 ***


Note You need to log in before you can comment on or make changes to this bug.