Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1513002 - Disk load utilization
Summary: Disk load utilization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Ankush Behl
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 15:03 UTC by Lubos Trilety
Modified: 2017-12-18 04:39 UTC (History)
6 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-4.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl monitoring-integration issues 252 None None None 2017-11-14 15:03:28 UTC

Description Lubos Trilety 2017-11-14 15:03:28 UTC
Description of problem:
There's a panel called "Utilization" (Bottom right corner) and it's unclear to the user what this is metric is showing. Is the the disk device capacity utilization or something else? Please make the label clearer as to what this utilization is about.

Moreover even when disk is used the chart remains on 0. The reason is in used metric on Grafana. There's
tendrl.clusters.$cluster_id.volumes.$volume_name.nodes.$host_name.bricks.$brick_path.device.*.utilization.percent_used
However such metric does not exist, there gauge_total, gauge_used and percent-percent_bytes in Graphite.


Version-Release number of selected component (if applicable):
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHGSWA and import gluster
2. Load some data
3. See Bricks dashboard

Actual results:
The Disk load utilization displays zero.

Expected results:
The chart should display correct percent of disk usage.
There should be some description about what the chart is displaying.

Additional info:

Comment 1 Ankush Behl 2017-11-15 19:55:19 UTC
@ltrilety@redhat.com 
>> The Disk load utilization displays zero. 

The Disk load utilization issue has been fixed and now the panel has got the value. But the label Issue is not fixed and we can track all the label related issues in a single bug. I think in this https://bugzilla.redhat.com/show_bug.cgi?id=1511687 we can track it.

Comment 2 Lubos Trilety 2017-11-16 12:33:12 UTC
I am fine with that if the title of the bug will be changed accordingly.

Comment 3 Petr Penicka 2017-11-16 13:13:00 UTC
Adding PM ack for 3.3.z since dev provided theirs.

Comment 5 Bala Konda Reddy M 2017-11-23 09:43:22 UTC
Verified in tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch

On an imported gluster cluster, pumped IO's on multiple volumes in the cluster. The information on the Bricks Dashboard, for disk utilization is showing correct information with time for different bricks.

Hence marking the bug as verified.

Comment 7 errata-xmlrpc 2017-12-18 04:39:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.