Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512995 - Panels in Gluster-at-a-Glance dashboard contain tables with bad layout instead of charts
Summary: Panels in Gluster-at-a-Glance dashboard contain tables with bad layout instea...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ankush Behl
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 14:57 UTC by Filip Balák
Modified: 2017-12-18 04:39 UTC (History)
7 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-4.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:57 UTC


Attachments (Terms of Use)
Tables (deleted)
2017-11-14 14:57 UTC, Filip Balák
no flags Details
Panels in 'Gluster-at-a-Glance' have been spaced and words don't float away (deleted)
2017-11-22 09:24 UTC, Rochelle
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl monitoring-integration issues 151 None None None 2017-11-14 14:57:47 UTC

Description Filip Balák 2017-11-14 14:57:48 UTC
Created attachment 1352016 [details]
Tables

Description of problem:
In specification for Gluster-at-a-Glance dashboard (https://github.com/Tendrl/specifications/issues/222) are following panels defined as charts:

> **Row 3**
> 
> Panel 17: Top volumes by capacity utilization
> 
> - show the top 5 volumes with the highest disk utilization
> - chart type: Bar Chart / Histogram
> 
> Panel 18: Top bricks by capacity utilization
> 
> - show the top 5 bricks with the highest disk utilization
> - Note: User should be able to discern which host the brick is mounted on
> - chart type: Bar Chart / Histogram
> 
> **Row 4**
> 
> Panel 19: CPU used by Host
> 
> - show CPU utilization for individual hosts within 4 different utilization ranges/buckets: > 90%, 80=90%, 70-80%, and < 70%
> - chart type: Heat Map
> 
> Panel 20: Memory used by Host
> 
> - show memory utilization for individual hosts within 4 different utilization ranges/buckets: > 90%, 80=90%, 70-80%, and < 70%
> - chart type: Heat Map

but in implemented grafana dashboards are those panels presented as tables.

These tables have also bad layout and are displayed incorrectly (not whole) on page. Their header cell `Utilization` is also incorrectly styled (it floats away). 

Version-Release number of selected component (if applicable):
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. Import cluster with volume and some nodes
2. Open Gluster-at-a-Glance dashboard

Comment 1 Ju Lim 2017-11-16 14:15:24 UTC
Reason it was implemented as tables vs. charts is due to long host names not displaying well in Grafana -- a Grafana limitation of not gracefully handling long names to show.

Suggested for the non-top 5 charts to change them to line charts and show their utilization as trends.

For top 5 charts, I suggest widening the table/panel so there will be less scrolling and improve readability.  This may result in the panels being on multiple rows to accommodate these changes.

Comment 3 Ankush Behl 2017-11-17 06:58:43 UTC
>> Suggested for the non-top 5 charts to change them to line charts and show their utilization as trends.

@julim@redhat.com I am not touching the non-top 5 charts for now. As it needs table panels to be removed and new panels to be added.

For now, I am just widening the width of the table panels so the readability of table panels can be improved.

Thanks

Comment 5 Rochelle 2017-11-22 09:24:18 UTC
Created attachment 1357320 [details]
Panels in 'Gluster-at-a-Glance' have been spaced and words don't float away

These tables have also clearer layout, spaced well and are displayed correctly on the page. Their header cell like `Utilization` is also correctly styled (does not float away). 


Moving this bug to verified

Comment 7 errata-xmlrpc 2017-12-18 04:39:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.