Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512991 - Kernel update broke dynamic CPU frequency
Summary: Kernel update broke dynamic CPU frequency
Keywords:
Status: CLOSED DUPLICATE of bug 1511701
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 14:54 UTC by Hemant Kumar
Modified: 2017-11-14 15:39 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 15:39:24 UTC


Attachments (Terms of Use)

Description Hemant Kumar 2017-11-14 14:54:42 UTC
Description of problem:

I have noticed this on two different Thinkpad laptops. One running Fedora 26 (via Korora Linux actually) and another running Fedora 25. I am currently running:

Linux pern 4.13.10-100.fc25.x86_64 #1 SMP Fri Oct 27 17:05:04 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

And CPU frequency is pegged to 2700MHz always. 

Output of lscpu:

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                8
On-line CPU(s) list:   0-7
Thread(s) per core:    2
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 94
Model name:            Intel(R) Core(TM) i7-6820HQ CPU @ 2.70GHz
Stepping:              3
CPU MHz:               2700.000
CPU max MHz:           3600.0000
CPU min MHz:           800.0000
BogoMIPS:              5424.00
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              8192K
NUMA node0 CPU(s):     0-7




I looked at other stuff that can affect this and found:

~> cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
intel_pstate

~> cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
powersave


Something suspicious I noticed when I started powertop:

~> sudo powertop
modprobe cpufreq_stats failedLoaded 24 prior measurements
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask f
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask f
Devfreq not enabled


I don't know if that is related.

Comment 1 Jeremy Cline 2017-11-14 15:39:24 UTC
Hello,

Thank you for the bug report. This sounds like a known issue. A fix landed in 4.13.12, but was reverted for 4.14 and is being reverted in 4.13.13 as it performs poorly on systems with many cores. A new fix is being worked on.

*** This bug has been marked as a duplicate of bug 1511701 ***


Note You need to log in before you can comment on or make changes to this bug.