Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512979 - Error When opening a generic object detail page for a service when the object has certain CB groups
Summary: Error When opening a generic object detail page for a service when the objec...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Aparna Karve
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1518316
TreeView+ depends on / blocked
 
Reported: 2017-11-14 14:41 UTC by lgalis
Modified: 2018-06-21 20:41 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1518316 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:41:35 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description lgalis 2017-11-14 14:41:39 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a Custom Buttons Groups for Generic objects in Automate->Buttons. Add button
2. Create a Custom Button group for a Generic object in the Automate-> Generic Objects. Add a button.
3.Attach the generic object created in step 2. to a service
4.Open the Service in MyServices - click on the generic object.

Actual results:
Error caused by the fact that the group_index is missing in the set_data for the button group created in the Generic Objects CRUD ui.

F, [2017-11-14T09:32:21.147608 #28583] FATAL -- : Error caught: [ActionView::Template::Error] comparison of NilClass with 1 failed
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:394:in `sort_by'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:394:in `get_custom_buttons'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:297:in `custom_button_selects'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:339:in `build_custom_toolbar_class'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:329:in `custom_toolbar_class'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:70:in `toolbar_class'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:18:in `build_toolbar'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper/toolbar_builder.rb:6:in `call'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/application_helper.rb:531:in `build_toolbar'
/home/lgalis/dev/manageiq-ui-classic/app/helpers/toolbar_helper.rb:7:in `block in toolbar_from_hash'

Expected results:


Additional info:

Comment 3 Aparna Karve 2017-11-15 19:02:09 UTC
PR - https://github.com/ManageIQ/manageiq-ui-classic/pull/2733


Note You need to log in before you can comment on or make changes to this bug.