Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512978 - [3.7] Fix support for CNS deployment
Summary: [3.7] Fix support for CNS deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.7.z
Assignee: Jose A. Rivera
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 14:37 UTC by Jose A. Rivera
Modified: 2017-12-18 13:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This BZ brings new features to the GlusterFS deployments, in particular the ability to provision glusterblock and gluster-s3 volumes.
Clone Of:
Environment:
Last Closed: 2017-12-18 13:23:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Jose A. Rivera 2017-11-14 14:37:14 UTC
The following PR needs to make it into OCP 3.7 ASAP, likely as an async advisory:

https://github.com/openshift/openshift-ansible/pull/5784

Without this PR, the OCP 3.7 openshift-ansible installer will have no ability to properly deploy CNS 3.6 or CNS 3.7.

Comment 1 Scott Dodson 2017-11-15 19:11:53 UTC
Here's a test build with Jose's fixes for CNS 3.6, we'll merge these changes into release-3.7 after it's been smoke tested and after 3.7 GA regression testing has completed.

https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=625394

Comment 4 Wenkai Shi 2017-11-28 04:23:53 UTC
This is block by BZ #1517225

Comment 11 Wenkai Shi 2017-12-11 10:02:11 UTC
Verified with version atomic-openshift-3.7.14-1.git.0.593a50e.el7, codes all merged. 
QE has tested full CNS/CRS deployment, all works well except gluster-s3. (BZ #1518108)
For standalone deployment, playbooks/byo/openshift-glusterfs/config.yml works well will document update (BZ #1520272 BZ #1520342), playbooks/byo/openshift-glusterfs/registry.yml still has issue. (BZ #1524342)

Comment 14 errata-xmlrpc 2017-12-18 13:23:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.