Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512932 - Inconsistency with required LCE/CV while creating host
Summary: Inconsistency with required LCE/CV while creating host
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts - Content
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 13:19 UTC by Stanislav Tkachenko
Modified: 2019-02-07 12:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 12:03:46 UTC


Attachments (Terms of Use)

Description Stanislav Tkachenko 2017-11-14 13:19:07 UTC
Description of problem:
API/CLI and UI treat differently whether LCE/CV is required when creating Host:
a) For API/CLI it is required only when creating host with associated hostgroup that does not associated with any LCE/CV. Otherwise they are not required.
b) For UI they are always required, however, those are not marked with '*' sign as other required fields.

So I'm not sure what behavior is expected: wether LCE/CV should be always required or should not be required at all.

Also if it should be always required update of APIDOC also needed as those options marked as optional.

Examples:
> # hammer -d -u admin -p changeme host create --organization-id=112 --location-id=111 --architecture-id=3 --domain-id=3 --operatingsystem-id=3 --partition-table-id=129 --name=test123 --medium-id=9 --mac="c4:e6:f5:33:b8:8b" --root-password="12345678"
> Host created

> # hammer -d -u admin -p changeme host create --organization-id=112 --location-id=111 --architecture-id=3 --domain-id=3 --operatingsystem-id=3 --partition-table-id=129 --name=test789 --medium-id=9 --mac="c4:e6:f5:33:b8:8b" --root-password="12345678" --hostgroup-id=2
> Could not create the host:
>  Content view can't be blank
>  Lifecycle environment can't be blank


Version-Release number of selected component (if applicable):
Since Satellite 6.3.0 Snap 19 to Satellite 6.3.0 RCM:
* katello-3.4.5-6.el7sat.noarch
* satellite-6.3.0-21.0.beta.el7sat.noarch
* foreman-1.15.6.3-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to create Host via UI but do not provide HG/LCE/CV.
2. Try to create Host via API/CLI but do not provide HG/LCE/CV.
3. Try to create Host via API/CLI providing HG but do not provide LCE/CV.

Actual results:
Results are different for API/CLI and UI.

Expected results:


Additional info:

Comment 1 Tomer Brisker 2017-11-14 13:34:38 UTC
Moving to Hosts-Content for further info on when these fields should be required and when not. (They are only required for content hosts)

Comment 3 Bryan Kearney 2018-11-30 14:59:24 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2019-02-07 12:03:46 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.