Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1512921 - [RFE] Enable OpenEXR support in ImageMagick
Summary: [RFE] Enable OpenEXR support in ImageMagick
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ImageMagick
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Horak
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 12:38 UTC by Daniel Helgenberger
Modified: 2018-11-02 01:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 838748
Environment:
Last Closed:


Attachments (Terms of Use)

Description Daniel Helgenberger 2017-11-14 12:38:38 UTC
+++ This bug was initially created as a clone of Bug #838748 +++

Reopening, as ImageMagick 7.0.4-3 is missing EXR support again:

# convert -version | grep Delegates
Delegates (built-in): bzlib cairo djvu fftw fontconfig fpx freetype gslib jng jpeg lcms ltdl lzma pangocairo png ps tiff webp wmf x xml zlib


Workaround: Downgrade to ImageMagick 6.7.8-9, which comes with EXR support:
# convert -list format | grep EXR
      EXR  EXR       rw-   High Dynamic-range (HDR)


** Original comment by rdassen@redhat.com **

3. What is the nature and description of the request?

Please enable OpenEXR support in ImageMagick.

Simply add an additional "BuildRequires" line to the ImageMagick spec file
before building:

"""
BuildRequires: OpenEXR-devel

"""

*NOTE: We (Red Hat) already have the OpenEXR-devel package available in our
RHEL Optional channels.*


4. Why does the customer need this? (List the business requirements here)

OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.

OpenEXR is used by ILM on all motion pictures currently in production. The
first movies to employ OpenEXR were Harry Potter and the Sorcerers Stone,
Men in Black II, Gangs of New York, and Signs. Since then, OpenEXR has
become ILM's main image file format. 

Customer has a need for OpenEXR support since they regularly interact with
images that are in this format. We already make both ImageMagick and the
OpenEXR-devel packages available externally. It would be a boon to their
work-flow to have the pieces already put together.


5. How would the customer like to achieve this? (List the functional
requirements here)

Having access to ImageMagick with OpenEXR support included.


6. For each functional requirement listed in question 4, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.

* The ability to create/manipulate OpenEXR images with ImageMagick

# convert -list format | grep -i exr
      EXR  EXR       rw-   High Dynamic-range (HDR)


7. Is there already an existing RFE upstream or in Red Hat bugzilla?

No.


8. Does the customer have any specific timeline dependencies?

If a 6.2 z-stream release is possible that would be optimal.


9. Is the sales team involved in this request and do they have any
additional input?

No.


10. List any affected packages

ImageMagick


11. Would the customer be able to assist in testing this functionality if
implemented?

Yes.

--- Additional comment from Platform RFE on 2012-07-10 03:22:31 CEST ---

** Original comment by notting@redhat.com **

Given that we already ship OpenEXR ... this seems pretty simple.

--- Additional comment from RHEL Product and Program Management on 2013-10-14 02:34:33 CEST ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

--- Additional comment from Benjamin Tissoires on 2014-01-29 22:32:15 CET ---

ImageMagick-6.5.4.7-7.el6 is available in brew

Comment 3 Jan Horak 2017-11-14 14:46:45 UTC
Hm, where did you get ImageMagick 7.0.4-3 from? It is not provided by RHEL 7.4, the RHEL 7.4 provides just ImageMagick-6.7.8.9. Could you please clarify it?

Comment 4 Daniel Helgenberger 2018-04-09 11:23:13 UTC
(In reply to Jan Horak from comment #3)
> Hm, where did you get ImageMagick 7.0.4-3 from? It is not provided by RHEL
> 7.4, the RHEL 7.4 provides just ImageMagick-6.7.8.9. Could you please
> clarify it?

Sorry, clearly my bad. This was a third party install.
Thanks, closing.


Note You need to log in before you can comment on or make changes to this bug.